Creating sunlight failed

I have a problem with creating “sun” in Rhino 5 (SR7). Everytime i am trying to set the sun into my scene, Rhino crashes from unknown reason. No message with description of this fail…Can somebody help me with this? I tried to find some topic with this question, but nothing found.

Thank you,

Hi Petr - I guess the first thing is to get the most recent service release here:

and see if that cleans anything up.


Hi Pascal, thanks for reply. Unfortunately, new service release did not help. Any idea how to fix it? Maybe important: I work with czech language pack in Rhino 64 bit. I don’t know, if this could have any influence…

I look forward to your reply.

Hi Petr - this is the Rhino sun, correct, viewed in a rendered viewport? (Not a third party renderer’s sun, I mean)

  • Has this worked in the past?
  • What is your video card and driver date (Options > View > OpenGL page)
  • Is iCloud installed on your machine?



Hi Pascal,

yes, we are talking about Rhino sun, not third party render’s suns.

  • it hasn’t worked since i have installed Rhino 5
  • Video Card - NVIDIA NVS 4200M/PCIE/SSE2
    - Open GL version: 4.4.0
    - driver date:
  • I haven’t iCloud on my notebook

thanks for the help

Hi Petr - if you see the McNeel crash report interface come up (?) during one of these crashes, please send in the crash info with as much detail as you can about what you were doing. I guess I might try a video driver update as well - yours is a year old, and sometimes a reinstall of drivers clears some cobwebs, it seems.


Hi Pascal,
i saw the crash report just once and i send it to McNeel. Ok, i will try update my video driver. i will let you know…

So, problem is still there. Now i have the latest driver for my video card (from23_9 this year)…but it doesn’t help. But have find out one (maybe important) thing. I tryied to switch to integrated video card Intel— and it doesn’t help also. Maybe this issue isn’t joined with video card…


PS: Rhino 32bit is ok with sun (i just can’t see the world map in there, but it works)

I’m having the exact same problem.

When I click the little box to turn on Rhino Sun, Rhino crashes. Happens every time. I can model for hours but activating the sun causes instant crash.

Before today I never had this problem.

I recently installed a bunch of Adobe CS products…new Anti-virus…could be a conflict with something?

I just updated Rhino service release today to see if it would help–appears not to help.

Any update on this issue?


Hi Michael - can you post a screen capture of Rhino Options> View > OpenGL page?



Just talked to phone support. The guy basically said my Intel graphics card is unreliable…he’s the one who recommended I uncheck "use accelerated hardware modes."

The problem does not happen if I unplug my external 2nd monitor. When I re-attach it, as soon as I click to check or uncheck the sun…crash.
Is my Intel graphics card just not up to the task of running Rhino? Anybody got an idea why everything worked fine until now?

Have you had any system updates? A newer video driver for the Intel card might have introduced an issue.
The 2nd monitor is as before? You haven’t increased resolution on primary or secondary monitor?

I did recently update all my Adobe CC software. Ext. monitor is the same but yeah, something with the intel card.

Unfortunately I have a Lenovo–the regular Intel update utility gives an error message that Lenovo has a custom configuration blah blah so go to them for an update. I would not choose Lenovo again for this reason :frowning: