Bug: sun and skylight

Help please!

As you can see in the video, turning „sun“ or „skylight“ once on and then off, the screen becomes totally dark. That‘s why I cannot use „sun“ or „skylight“. So what‘s wrong? Thanks for any help!

Run the Rhino command _SystemInfo and copy&paste the full result from the resulting dialog.

Wild guess: old drivers or insufficient GPU.

Thank you! This is the result of _systeminfo. So what‘s the solution?

Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Evaluation, Build 2022-03-08
License details: Stand-Alone
Expires on: 2022-07-02

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 7.9Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: ATI Radeon HD 4800 Series (AMD) Memory: 1GB, Driver date: 1-13-2015 (M-D-Y). OpenGL Ver: 3.3.11672 Compatibility Profile Context
> Accelerated graphics device with 2 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 3.3 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 3.3
Shading Language: 3.30
Driver Date: 1-13-2015
Driver Version: 8.970.100.9001
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Your graphics card is not able to do everything you ask from it. It falls quite a bit short from the system requirements for Rhino 7 . You need a card that supports OpenGL 4.1 minimum, your card is capable of only OpenGL 3.3

Alright, thanks!

Hi -
Just note that you can also change the OpenGL version that Rhino targets.
As Nathan wrote, Rhino 7 uses version 4.1 by default.

You can change this with the Level slider in the Rhino Options -> View -> OpenGL page.
Moving that slider one notch to the left will make Rhino target OpenGL 3.3.

Note, however, that this does not mean:

  1. That 3.3 will work for your hardware-driver combination: lots of GPU drivers have bugs and don’t correctly implement the OpenGL level they advertise to be be supporting
  2. That everything in Rhino 7 will work as it does on hardware that fully supports OpenGL 4.1: targeting a lower version means not being able to do some of that things that are possible in a higher version