Crash after latest update

Dear McNeelies,

I updates my Rhino6 as suggested and installed rhino_en-us_6.0.16124.12581.exe
Now Rhino 6 crashes when:

  • I try to open any file
  • I try to save any file (as simple as a single cube)

Tried to re-run the installer. Seems like there is something wrong there too. I get “Error Code: 0” and a report: (1.3 KB)

Would be great to get Rh6 working again. I love it.

PS: will try to uninstall and reinstall. I let you know if that helps.

Thanks for your great work on the new product!
Cheers, Frank

System report:

Rhino 6 SR0 2016-5-6 (Public Build, 6.0.16127.5131, Git hash:73bbb016ce086c682fa2f0736442f5ed95a046a8 in branch n/a)

Windows 7 SP1 (Physical RAM: 16Gb)

GeForce GTX 660 Ti/PCIe/SSE2 (OpenGL ver:4.3.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.3
Shading Language: 4.30 NVIDIA via Cg compiler
Driver Date: 3-14-2013
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2096832 KB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript” n/a
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a

Uninstalled and re-installed version (6.0.16130.4271, 09.05.2016)

Still crashing :-/

Start rhino,
click on _Box button, draw a box
STRG + S (save)
—> Crash

Pls find the crash report below:
RhinoCrashDump.7z (5.6 MB)

@tim can you please look into this crash?

Hi All,

I took a look at the dmp file in dev studio and there is nothing of value that I was able to glean from it. I guess I would try the Safe Mode route to see if you can isolate a particular plugin or video as a culprit. Sorry I can’t be more help.



It sounds like Rhino is crashing after you run the Save command.

Are you starting with a new clean template, or saving an existing model?

There’s actually a lot that happens in the Save command:

  1. Rhino opens a file dialog so you can select the file to save
  2. You enter a filename and then click Save
  3. Rhino writes the file

I’m curious, do you see the file dialog box at all? I wonder if Rhino is crashing because a shell extension is loading into your file save dialog box.

Hi, I just updates WIP. Made 2 mesh spheres, unioned then, preview subd from holo tools. Then program has to close. Maybe Holo’s toolset doesnt like this WIP

@Holo, just wondered if youve tried the tools you made for subd. Program wont stay running.

The SubD stuff in the WIP hasn’t seen a lot of love from us lately, either. Are you getting an option to submit an error report to us? If so, please send it.

No it isnt asking

This one sounds like is covered here:

1 Like

Hi, the preview uses the SubdFromMesh command (it just automatically hides, unhides and deltes the subd)

So please check to confirm that SubdFromMesh causes the same crash. (I posted a similar crashreport yesterday, or the day before)


Hi Holo, I tried the same order of operations 3 or 4 times and Rhino says it doesn’t want to play. — Mark

I did some bugtracking now and wireframe and rendered works ok on a simple 3x3x3 mesh box, but once shaded is active it crashes.

SubD isn’t going to make it into the shipping Rhino 6 product, and we’re focused on fixing bugs related to Rhino 6 first. Don’t expect SubDs to be useful for a while, please.

Hi Brian,
actually R6 crashes when I draw a _Box too…

  • open rhino
  • click on _Box button
  • crash

— Last thing I can read in the command line is “Creating meshes… Press ESC to cancel”

on a second try, I managed to finish the _Box command, but when I invoke _Shaded -> crash.
obviously related to meshing

PS: I just installed to latest suggested update.

Does Rhino ask you to send in an error report? If so, please send it.

Hi Brian, no it doesn’t.
Can I find it somewhere?

That’s what I was afraid of. I’m seeing more and more instances of our
error reporting system not actually trapping and reporting errors.

I’m not sure if this is a crash in the mesher, or in the shaded display.
Here’s one way to tell:

Test 1:
Draw a MeshSphere
Change to Shaded display

Test 2:
Draw a Box
Select the Box
Run the Mesh command

Do either or both of these crash?

Test 1:

  • maximize perspective viewport
  • make sure its shading mode is “wireframe”
  • _MeshSphere , click, click
    —> crash

Test 2:

  • maximize perspective viewport
  • make sure its shading mode is “wireframe”
  • Draw a Box
  • Select the Box
  • Run the Mesh command
    —> still doing fine
    change shading mode to “Shaded”
    —> Crash

Yuck. There was a new builds released yesterday. Please download it. Does
it still crash? What if you start Rhino in safe mode?