Corrupt files on rhino causing problems

It seems that my rhino has been corrupted. I was using the grasshopper3d pufferfish plugin earlier this year. The file was very heavy and was not able to convert into a make 2d linework. I sent that file over to a friend who also has an educational licence but it didn’t work and in the command bar, it said that the file was corrupted. We even tried it on a gaming laptop but it failed and the same message showed up. It caused a lot of problems during my submission. I’ve since deleted all those files and have started afresh. This time I have been doing some hatching on rhino and eveything seemed fine until I tried to covert it into a pdf . The file was just 1mb and I don’t think it should’ve posed a problem , but it did . I even emailed my friend the file so that she could try it on her laptop but it didn’t work either.This time no message about the file being corrupted showed up. whenever I use the export command, the rhino stops responding. After waiting for sometime it gets saved but the pdf is size is Soo huge that it doesn’t open on my computer. Even if there are 28 hatches and 4 curves , the file still comes out huge . I recently emailed the rhino tech team and they are able to download the pdf and the size is also small (2mb) but when I use the same steps they told me to use , it’s still over 25mb. This probably means that theres some problem with the rhino application on my laptop. I have a submission next week and I have to use rhino for it . Will it work if i uninstall and reinstall the application? Or is there any other solution.

You really need to give a bit more detailed info on what you ran that said what file was “corrupted.” It’s incredibly unlikely your Rhino is “corrupted” and still works at all. What are you using to make the PDF? What settings are you using? “Not responding” messages don’t mean anything more than Rhino is busy.

What do you call “huge?” I mean, a 25mb file is not actually huge these days, it’s a bit big for a PDF but it depends on what it is.

Is Rhino up to to date? Run “SystemInfo” and post the results…

1 Like

I deleted the corrupted file a while back. But the reason I’m saying its corrupted is because whenever I opened it, a message in the command bar would pop up saying the user object has been corrupted. It was probably because i was using grasshopper3d with the pufferfish plugin at that time. As for the system info, I’ll paste the results here :Rhino 6 SR28 2020-7-17 (Rhino 6, 6.28.20199.17141, Git hash:master @ b1f15b655bd1f5ae0d3d3257e3efdeb0a45630e4)
License type: Educational, build 2020-07-17
License details: Cloud Zoo. In use by: Amritha Bharadwaj ()

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: LAPTOP-3CDPBFAR

Hybrid graphics system.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 8-5-2020 (M-D-Y).
Primary OpenGL: NVIDIA GeForce MX250 (NVidia) Memory: 2GB, Driver date: 8-12-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.06

Secondary graphics devices.
Citrix Indirect Display Adapter (Unknown) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-12-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.28.20199.17141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.28.20199.17141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.28.20199.17141
C:\Users\AMRITHA\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.20090.750
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.28.20199.17141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Users\AMRITHA\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Twinmotion Direct Link 2020 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Your systemInfo looks fine except you’re way short on VRAM for V6.
That system probably worked pretty well for V5.

I suspect the problem is in the 3dm file.
Does SelBadObjects select anything?
You might try SaveAs and don’t export any plug-in data with it to see if the new stripped file works better.