Correct silhouette behaviour

Hi Rhino developers.
I think the default Rhino 8 WIP silhouette graphic representation is incorrect and not very elegant.
3DS Max shows a correct outline also if I select separated objects.
The thicker line surrounds all the selected objects, the thin one shows the intersections.
Your shader shows overlapping silhouettes, very confusing. In fact I disabled it.


There are two possible modes for Silhouettes. Search for silhouette in advanced settings and change the mode between 0 and 1 to see the differences.

Pls note that there is currently a bug with silhouette highlighting and Subobject selections, esp. with regards to SubD objects.

Hi @Gijs
I’m only seeing the option to turn it on/off.

Is it in an in-house build or…?

@Normand it should be in the latest build, let me know if it isn’t

1 Like

Thanks, @Gijs
I was just a version behind! Great option - I like it a lot!

Good to hear. As for this 2D silhouette feature, it has the problem that when a smaller object is behind another object that is selected, and you make a window selection, this object will not be visibly selected.

Also, I have noticed that silhouettes in general take more resources, since they need to be calculated on the fly. In complex scenes you might get a noticeable performance hit.

Please let us know what works and what doesn’t work for you when working in this mode. Silhouette highlighting is in its early state of development, and since it affects how you interact with Rhino globally, needs getting used to and longer sessions to test drive.

Yeah, I’m kindda used to that from Keyshot :grimacing: But having the option is great! I’ll test it (and will probably end up going back to “ordinary” highlighting because I’m old, not very adaptable and used to the way it has looked since I started using the beta version in ´97 :joy:).