Copy text from layout to model space - does NOT show

When I try to copy a text from layout to model space, the text is probably not copied or is invisible, it simply does not show up. Some kind of bug? Copying of other geometry works.

1 Like

I think the last time I tried this, it did copy, but since the origin in the layout is not the same as the origin in model space, it went somewhere unexpected… I need to check again though. Maybe it went off the layout area?

Ah, and I am on Windows, so there might be a Mac-related bug I guess.

Hi Petr - just tried this on Mac and that seems to work.
Any details?

Hi @wim
sure, here it doesn´t work at all.
steps are:

  1. open a new document (whatever template)
  2. create a layout - default settings confirmed
  3. text placed in the middle of the page
  4. select the text, cmnd + C
  5. getting back to model space - top view - cmnd + V
  6. no text appears, neither select all nor zoom extent work - the text is not there

running Version 6 (6.23.20035.13182, 2020-02-04)

edit: It doesn´t work on R7 WIP either…it might be related to something on my mac. Any thoughts what shall I look for?

No - I can repeat that here now. I’ll get it on the list.

Cool! Thank you


Thanks for reporting - this is now RH-57200 and seems to be busted on Windows also.


Did you try the ChangeSpace command? Ctrl+C / Ctrl+V has never worked for me. Select the text, run ChangeSpace, click on the detail view edge when prompted…

I tried that on Mac and that works, yes.

Seems like that works fine on Rhino 5.

I don’t think I did much with layouts in V5…

copy paste works on R5 not as convenient as changespace though. on the other side i cant test this on R6 since copy paste is deactivated on my ran out trial, but i remember it not working when i still had a valid R6 licence.

Yes I tried, it works.
In my case, it would be just faster to copy paste. I needed certain symbols in 1:1 and I had only the text sitting in the layout. So I was wondering if this was a bug on my side or some general issue that could be fixed in the future.

Agree, and since this works in R5, I see no point in not having that in R6 :slight_smile:

Hi Petr - apparently, because of a number of related bugs, it was decided that annotations cannot be copied from paper space into model space. You will have to use ChangeSpace from now on.

ouch, okey, thanks for letting me know

I had this problem in rh7 today and had to find a workaround.

Well actually this can be done very easily with any number of gh plugins:

Jep, this is still an issue. Something I would never have thought of being a problem. Most other elements were copied without an issue, no text.

Hi -

As I wrote 2 years ago, because of issues, this is the way that works.
You need to use ChangeSpace.

Hi Wim,

just bumped into this problem in rhino 7. (windows)

Basically I need to copy elements of a plan header from layout space into the model space but and Text won’t show up.
Quite a common (and necessary) workflow in previous Versions

changeSpace only works between Details/Layouts so that won’t help. or did I miss something?

what I did notice though: I can make a block inside the layout, and copy the entire block from Layout into model space and explode it again.

seems awkward :upside_down_face:

never mind… got changeSpace to work fine now.