Copy paste not working

Hi,

Copy paste command is not working in my grasshopper alongside with delete, and alt+drag command (copy with alt key). I am using Windows 10 and Rhino7 with preinstalled grasshopper.

It seems like every time I try to copy paste or do any of the before mentioned operations, I trigger a command in Rhino7 rather than in grasshopper. I read about this issue on many Grasshopper forums, tried reinstaling Rhino7 on my computer, rebooting my computer, but nothing seems to fix the issue.

Is there any solution to this issue? Thank you for your help

CTRL-C and CTRL-V work for me (see Edit menu), are you using something else?
DELETE key also works as expected.

alt+drag in Grasshopper splits the canvas, which is weird but expected. I’ve never heard of alt+drag to copy anything?

The intention was probably to say: start dragging a component, then press alt while dragging. That allows to create a copy of a selection.

Have you found a solution?

Hi Sebastian,

Can you describe your issue a little more? Are you getting Grasshopper commands in the Rhino command line right away, or after working in a particular file?

Here are a couple ways users have reported to have fixed this issue.

  1. If using two monitors ensure that they are the same resolution.

  2. Maximize the Grasshopper window in a way that it will be visible on just one screen. Any part of the Grasshopper window can not exceed your primary screen. First, try to minimize the Grasshopper window and then change the size in order that fits in your primary screen and then maximize. It has to appear just on one screen.

The alt drag works except for groups and any related tags, it only works for the actual components.

I’m getting the same issue. I get an error message about clipboards and virtual machines having notorious difficultly in accessing the clipboard. The msessage says you can paste in grasshopper but not outside.

I was able to paste into grasshopper without an issue after closing the message. Now that I hit ignore the message I get the following message and can no longer paste into grasshopper after copying.

Is there any usecase for pasting from grasshopper to other programs? Maybe its better to have copy paste just be available for grasshopper and not try to use the windows clipboard.

I’ve had issues with copy and paste in Power Point. So I think its just an issue with windows in general.

ctrl-c and ctrl-v work with me try also using delete key work

I’m facing the same issue. Any solutions to this problem yet?
It’s quite urgent…

I wen to the system clipboard settings, Cleared it all … and GH worked fine afterwards
Hope this helps

1 Like