Copy Paste Blocks only working on the second attempt, but with duplicates

Hi there,

I have some odd experience with copy pasting blocks.

When I copy blocks from a model (in the case I just had nested blocks, but it also happens with non-nested blocks) and I past them in a new (let’s say blank) model they are not visible.
After I paste them a second time they appear, I get the message asking if I want to replace the existing definition, which means they must already be there - at least their definition.
Then everything appears, but I need to delete the duplicates.

Is this a bug or is something wrong on my machine?


Hi Tobias -

I’m not seeing that here.
Could you provide a simple 3dm file and the outcome of the Rhino SystemInfo command?

Hi @wim,
I just realized it might be connected to VisualArq, that opens for some files that contain ifc-content.

I exported the object to a new file which is attached here.
Screw.3dm (280.9 KB)

Rhino 7 SR21 2022-7-27 (Rhino 7, 7.21.22208.13001, Git hash:master @ c31aea87137a5d0de449338a7ef6856f49dd4797)
License type: Commercial, build 2022-07-27
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP  - Plugged in [98% battery remaining]

Non-hybrid graphics configuration.
  Primary display and OpenGL: NVIDIA Quadro P3200 with Max-Q Design (NVidia) Memory: 6GB, Driver date: 10-19-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 517.66
    > Integrated accelerated graphics device with 4 adapter port(s)
        - Windows Main Display is laptop's integrated screen or built-in port
        - Secondary monitor attached to adapter port #1

Secondary graphics devices.
  Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 11-15-2021 (M-D-Y).
    > Integrated graphics device with 3 adapter port(s)
        - Secondary monitor is laptop's integrated screen or built-in port

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 10-19-2022
  Driver Version:
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp	"Tibidabo"	

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.21.22208.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.21.22208.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.21.22208.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.21.22208.13001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.21.22208.13001
  C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Users\tstoltmann\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp	"SectionTools"

Hi Tobias -

I’m not seeing that behavior with that file either.

I’m not running VisualARQ here - have you tried to reproduce it when that plug-in is disabled and Rhino restarted?
Apart from that, you’re quite a few Service Releases behind the current version…

Thanks Wim.
Unloading the plugin solved the problem as far as I can see.
So, would it be possible to move this thread to the VisualArq-Branch of the forum?

And I am 100% aware of the service releases, our admins claim it’s company policy to install service releases every 3 month - I think they just do not care. :frowning:


1 Like

Hi @tobias.stoltmann,

I tried to reproduce the problem but I couldn’t do it. Here is what I am doing:


Is this the workflow you are following?

Exactly. Is it possible you create the block with VisualArq activated?

Hi @tobias.stoltmann,

Yes, VisualARQ was activated. Just in case, do you have other plug-ins installed in Rhino?

Did you unload only VisualARQ during this test or did you unload all the plug-ins installed in Rhino?

Hi @tobias.stoltmann,

Which versions of VisualARQ do you have currently installed?
We fixed a very similar bug in VisualARQ 2.10, which is quite old.


@enric I will get our IT-dept to update VisualArq.
My version is (2020/11/04)!!
They are not the most supportive when it comes to updates as you can see. :slight_smile: