BUG? Rhino 6 suddenly can't copy-paste blocks between instances

Hi @pascal @wim

I usually copy paste stuff between two instances of Rhino and now suddenly I can’t copy-paste blocks.
Has anything been changed regarding Rhino’s massive copy-data situation that can have affected this?

Please open this file and copy the block object to clipboard with Ctrl-C and then open a new instance of Rhino and paste it in. Here it pastes but no object becomes visible. (All layers are on) and if I SelAll nothing is selected. If I then type INSERT I can find the object in the block list, but I still can not insert it… strange stuff.

If I make a clean, new Rhino document and make a simple test block then I can paste that into a new Rhino file. And to make it worse, I can copy paste this block within the same Rhino file… so what is going on??? :expressionless:

BLock copy paste example.3dm (491.7 KB)

Hey, I found some bad objects in the main file that caused the blocking for some odd, strange, far above my paygrade thingo.

Extracted them here:
Bad Objects.3dm (548.3 KB)

Update: Later on I pasted another block in and got the same problem.
Blocks added to block list, but no object in file nor ability to insert them.

But… If I made a new block with the same name within the rhino file and chose to replace it, then it works and suddenly those other blocks placements I tried to add also got the new block placed on them… so surely an odd thing.

@pascal and @wim did you have time to take a look at this?

I encounter this on some files now and after pasting it in I get this if I open the blockmanager.
The blocks has been copied, but they appear to be empty:

image

This is something we have done for years with no problem at all, so I wonder if a “purge” got implementet into Rhino6’s copy - paste thing that removed blocks too???
If so I need to go back to an earlier SR.

Hi Jorgen - thanks for the bump. I’ll test…

-Pascal

This is odd, it works just fine on my brothers machine,
so I disabled some plugins and tried again and same issue.
BUT if I paste one more time then I get asked to use the new block, use the old, or both and if I choose either use current or use new then it works.

So I have to paste twice, and then delete the duplicate, because then the first paste pops up too…

This is very strange.

(Plugins I disabled from loading: Bella, Enscape and TwinMotion. I also have VisualArq, but I didn’t disable that one. I can try tomorrow)

Hi Jorgen - the basic action to test is:

  • Have two Rhinos open
  • Make one or more blocks in one Rhino
  • Copy a block instance to the clipboard
  • Paste into the other Rhino

Correct?
At least on a first quick test, this works as expectd here…

-Pascal

Yes, and then test with the two files I posted above please.

Yep, I see the problem here as well, with your file - no ideas yet… but I notice VisualArq may (?) be involved somewhere here.
I see a second paste with replace works as well, as you described.

RH-61577 Paste: Pasted block fails
@Holo - this appears to be related to VisualArq. Is that on your machine?

-Pascal

Ah, great (well, more of a “great” actually) that you could reproduce it, and also the dual paste. Good luck with figuring it out and shout out if I can be of any assistance.

One thing, my brother’s machine also has visual arq installed, but not the two latest builds. He just tried the eval. So maybe it is deactivated. I’ll check more tomorrow, being able to copy paste between two rhinos is important :slight_smile:

By the way, here’s a great xmas wish :smiley:

1 Like