Copy from AutoCad behavior change

Hello.
Today I copied some lines and hatches from Autocad using ctrl+c and pasted them to Rhino using ctrl+v. I have the latest release of Rhino 8 installed. The last time I remember doing that the objects from AutoCAD were pasted in the same world coordinates in Rhino. Today I copied an object with large coordinates from AutoCAD and when I pasted them to Rhino they went to 0,0.
When this change? Is there an option to paste them to the same coordinates without using the import command?
Thanks

Any help, please.

Hi @ar00302,
Please attach a DWG that we can test with with.

Also open Rhino, type the command SystemInfo.
Copy and paste the results into your reply here.

Also, what release of Rhino did this work in?

Thanks,
Mary Ann Fugier

Drawing1.dwg (462.5 KB)

Rhino 8 SR10 2024-7-1 (Rhino 8, 8.10.24183.02001, Git hash:master @ 8896e2267c5df7607a4f57f13a377c3e60b0ed78)
License type: Educational, build 2024-07-01
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 64GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 6-1-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.99
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-1-2024
Driver Version: 32.0.15.5599
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\8.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino8.rhp “Datasmith Exporter” 5.4.2.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.10.24183.2001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.10.24183.2001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.10.24183.2001
C:\Program Files\Rhino 8\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.10.24183.2001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.10.24183.2001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.10.24183.2001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

I don’t remember which was the latest version it used to work as expected.
It used to work like copying and pasting between two rhino files where the pasted object is always at the same coords as the original.
For sure the first version of rhino 8 used to work as expected.

thank you

1 Like

Hi @ar00302,
I see the issue.
I logged RH-82933/Paste-from-AutoCAD-Uses-Wrong-Coordinates and let you know when we have a fix.

Sincerely,
Mary Ann Fugier

uhmm, when I copy/paste from autocad to Rhino it does it as a ‘picture’ ?? V8 latest release

Did you try with the file that @ar00302 provided above?
It pastes curved for me in the very latest internal build Rhino 8 sr10 release candidate.

@milezee if you have a DWG file that pastes as an image, please post it so I can test it.
Thanks,
Mary Ann Fugier

Are you copying geometry from AutoCAD and not the file from Windows Explorer, correct?

yes, open autocad file, highlight geometry, copy then paste into rhino, this just gives inserting a picture option. Is the correct way to copy the file from explorer an paste into rhino ?

yes I’ve tried the dwg from @ar00302 and my own, I highlight geometry in autocad, ctrl+c and then ctrl+v in a rhino window. Rhino behaves as if I have run the ‘picture’ command :man_shrugging:t4:, system info below,

Rhino 8 SR8 2024-6-18 (Rhino 8, 8.8.24170.13001, Git hash:master @ c3cc7c123163b65d85b517aff795627d5b12166b)
License type: Commercial, build 2024-06-18
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 64GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 4090 Laptop GPU (NVidia) Memory: 16GB, Driver date: 6-1-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.99
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA GeForce RTX 4090 Laptop GPU (NVidia) Memory: 16GB, Driver date: 6-1-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.99
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-1-2024
Driver Version: 32.0.15.5599
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16376 MB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\8.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino8.rhp “Datasmith Exporter” 5.4.1.0
C:\Users\mdexter\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.3.0
C:\Users\mdexter\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\SubstanceImporter\2.0.7\Substance.Win.rhp “SubstanceImporter” 2.0.7.0
C:\Program Files\Rhino 8\Plug-ins\BlockEditNew.rhp “BlockEdit” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Users\mdexter\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

@milezee
Here are my steps:
2024-07-10_09-44-29

You may want to disable all your plugins that do not ship with Rhino.
Close, reopen Rhino and test.

Also Rhino 8 sr9 is being released today as the Public release of Rhino 8.
Install that and see if it is any different.

Sincerely,
Mary Ann Fugier

hi Mary, disabling installed plugins does not affect anything, I still get the same behaviour when copy/paste from autocad to Rhino, its as if I have called the picture command. I have checked for updates and sr9 not available to me yet

What version of AutoCAD? I am using 2023, not the newest but not the oldest either.

The Clipboard is can hold different types of data.
So that makes the Paste is complicated in Rhino.

It is great to be able to Paste an image that you copied into Rhino as a Picture.
But, there is no option to “snag” only vectors from the clipboard.

You are the only one reporting this.
Until there is a break here, you will need to import or insert a Dwg.

Sincerely,
Mary Ann Fugier

autocad 2024 , we have 4 Rhino licenses and same behaviour across the 4 machines

FWIW, I am unable to repeat with AutoCAD 2024 and Rhino 8.9 (latest release candidate).

– Dale