Continuous print problem with rhino 7 Mac


I keep having problems to print from rhino 7 for Mac. The is what I want to print:

This is my print menu:

Whether I print directly on my Epson SC-P800 or via Pdf, no difference, this is what I get:
Kasten-2.pdf (266.0 KB)
This is the Rhino file:
Print-Problem-2021-6-24.3dm (2.5 MB)
I work on an iMac from 2013 in Mojave.

I have posted this problem already 2 months ago and then got the advice to use the export to pdf function. That worked then, but today Rhino crashed when I tried this again. I pasted the crash report I got below.

This problem is beginning to get tedious … I mean, I can’t be the only Mac user who needs to print drawings and templates from Rhino. Does it work on other Macs?

I would very much appreciate help, because this function is needed quite often.

Best regards - Jan

Print problem crash report.txt (140.8 KB)

… oh, I forgot: this is the failure notice I get when I try to export the drawing:
Failure notice

Do you have the same problem if you save your file to your Desktop or to a subfolder in Documents?

Hi Jan - what happens if you set the output to vector rather than raster?


John: no matter where I save the original file and where to I try to export the pdf, it doesn’t work. Either I get the messed up result of the pdf already posted, or Rhino crashes, or I get the „Failed to save“ notification. I can’t discover any system in when Rhino crashes or when writing plug-in failed.

Pascal: no difference whether I export as vector or raster, whether in color or black and white.

What build of Mac Rhino are you running?
There have been some recent changes that have not yet made it to the released builds. My guess is they are in the Service Release Candidate.
The most recent one about Vector printing skipping annotation text was just fixed and will be in 7.9

Also, for reasons unknown to me, using the Export command and using the Print command can produce different results.
Something worth trying.

I am running Version 7 (7.7.21160.05002, 2021-06-09)
Maybe I’d best wait for 7.9 and check whether that works then. Any idea when that will be?
Thanks anyway, cheers - Jan

Now I found a workaround: export to Adobe Illustrator, open in Illustrator and print.