Continuous PIPE

Can I pipe a polyline to be as continuous as a sweep? I have a series of polylines in the location of my handrails. The open curves are faceted. I created them by joining 5 straight lines. Everytime I pipe these open curves, the pipe is fragmented (one individual cylinder for each facet of the curve). How can I pipe these curves to be continuous and smooth? I want the bends in the pipe to look mitered. The picture below is what I keep getting.

If you pipe a simple polyline, it should already do what you want.

Maybe something is wrong in your starting curve/polyline. Can you upload it here?

1 Like

RHINO HELP_Sweep Continuous.3dm (143.4 KB)

Hi Matthew - not sure what is going on here, I’ll see if I can figure something out - some of the polylines have some very slightly non-tangent segments here and there,


which I’d fix if those are not intended, but there is more than that going on…
@matthewpgordon - the file tolerance is set to 0.0
… that should not be allowed.
RH-70100 DocumentProperties: Absolute tolerance of zero

Please try setting that to .01 or smaller, but not 0.


1 Like

So the polylines were created with the polyline tool. I always get NON-TANGENT lines regardless of my tolerance. I don’t know why. I typically set my tolerance to .001 at most. The file you received was a quick cut-and-paste from a much later file with that tolerance. I will try it again. Thank you.

Hi Matthew - polylines are of course typically non-tangent , I was pointing out pairs of segments that are so nearly tangent, I thought it might be unintentional, and could be replaced by a single segment - but if not, not.
There is still something not working right with Pipe though… still digging.
It does look like removing those short nearly-tangent segments helps.


1 Like

Is R7 rounding it? - in R5 it is shown as 1e-80 !

I get the same (Rhino 5)

Your artefacts appear with a tolerance of 0.00001, but not at 0.0001 or 0.001 so the very fine values are spooking the Rhino.

Unfortunately you get different artefacts with the more realistic values.

If you move the object from its current location to the origin then there is a marked improvement.
So these new artefacts are probably display mesh issues. If the objects have to stay distant from the origin then using a custom mesh can improve matters. These, by no means definitive, settings help:

But meshing will take longer… …and anyway you may not want to display images at a level of detail where these artefacts show up, in which case ‘smooth and slower’ may be adequate.


1 Like

This is very helpful. Thanks for looking into this for me.