Pipe hassle

just tried to pipe a polyline with 4 segments and specified two different values for the start and end diameters. worked fine.
then i played around with the different pipe options. finally tried to reproduce the original output, but now i always get a set of untrimmed cylinders, one for each polyline segment. tried to reset all the options, also restarted rhino. but pipe still outputs untrimmed cylinders.

Hello - without a file and some instructions to reproduce the problem, it is hard to know how to help…


FWIW, I’ve tried this on Rhino 5, 6, 7 and on the Mac and can never get Pipe with unequal start and end diameters to create mitered corners on a Polyline. @pascal, is that something that works on your end?

@wim @brt1 - it looks like it needs ‘FitRail= Yes’. (V7… it also makes untrimmed miters. still poking…) In V6 that does not help, so I am not sure how you (@brt1) got your initial ‘ok’ results.

if the polyline is flat, it works reasonably ok. not in all cases.

sorry, took some time to answer.
meanwhile, after some restarts pipe with constant radius works again as expected (something must have been reset).
i did so many tries, that i could not remember which ones worked after all. variable radius, as you and wim stated, produces untrimmed cones.
i attached both examples:

pipe_fails.3dm (184.3 KB)

Hi - I think that is expected behavior in Rhino 6.
@DiegoKrause, could you post an example where this works (i.e. creates trimmed miters) on a flat polyline?

no, I can’t, because I read it all wrong haha I didn’t see the part about variable sections haha.

1 Like