Compute.geometry has stopped working bug

Hi McNeel,
around 50% of the times I close Rhino I get the following.
Thanks - S


Hi Silvano -

I take it you are not simply launching Rhino with a factory-default template and closing it right away and then getting that dialog box half of the time?
Can you provide more information on what you do that might lead to this?

Hi Wim, I investigated briefly and indeed, not using a factory default template and not saving the file, then closing it causes this crash. I’ll DM you the template. Thanks - S

compute.geometry is the process that hops starts to solve definitions. There is probably a gha installed which is causing problems when it is running inside of compute.geometry

Hi Silvano -
Thanks for that file. As Steve writes, you probably have a gha installed that is causing this.
Your custom template file loads VisualARQ, which, in turn, launches Grasshopper, which (: ) loads all of your Grasshopper plug-ins. You could try a “load one-by-one” to find the offending gha.

When I open Rhino and load GH (including VisualArq), then close again → no crash. It only happens when I load this template. Also loading one of the VA templates does not result in the crash.

Is there an option to block GH from loading certain ghas?

Hi -

That would be the GrasshopperLoadOneByOne option. But it might be easier to temporarily move ghas to a different directory?


Before I started looking into this, I wanted to test again with standard loading of GH and opening the template - and I cannot reproduce the bug anymore.