Command Autocomplete customisation

Hello,

I’m having a headache with certain command ‘shortcuts’ that autocomplete incorrectly (by my definition of what I think the autocomplete should logically or more likely be). By this I mean, if I type ‘mi’ into the command bar and enter on a fresh install of Rhino, for example, it’ll autocomplete with ‘minimise’ and shut the window.

I use multiple computers for work, and so certain ones that I use more regularly will have the autocomplete functions filling in to my liking, and others where rhino has been recently installed will have different ones. This is a pain when I’m modelling quickly as I’ll type ‘mi’ + enter out of habit, and it’ll then close the window, which then reinforces the likelihood of that command being the one that autocompletes when I type those letters. This slows down my modelling speed a lot.

Is there a way to set command autocomplete shortcuts for rhino, so that when I type ‘mi’, or whatever, it always gives me the command that I want; and to make it so that I can export these settings to each computer? Of course, there’s shortcuts that you can set but these seem to be only individual letters or command + whatever other key.

Yes, if you create a specific alias (Options/Preferences>Aliases), it will take precedence over the autocomplete.

If you create an alias for ‘mi’ that launches a particular command, then typing ‘mi’ and Enter will always launch that command. The autocomplete list will still be there as well in case you are for some reason looking for another command that starts with ‘mi…’.

1 Like

Thank you, that’s exactly what I was looking for!