Closed polysurfaces becoming see-through

Hi all,

I’m working in Rhino 5 for Mac running Mojave 10.14.6. I’ve been having an issue where I can see ‘through’ solids when I am at certain angles. The drawing is in shaded, and it happens for both open and closed polysurfaces, as well as unjoined surfaces.

This started happening maybe 6 months ago. It doesn’t stop me from drawing, but it’s pretty bothersome. Has anyone seen something like this before? Is it something obvious I’m missing? Screenshots below.

Thanks!

Hi,

Can you post a model where this happens? I’ll take a look. My first guess is that there are very large scene extents so I’d first look for objects off in the distance or check how far the model was from 0,0,0.

Hi Brian,

My model is attached below. There doesn’t seem to be all that much in the distance, but it is a bit of a messy file with objects spread out a bit.

uxbridge_site-plan.3dm (11.9 MB)

hmm thats weird, the objects dont seem too far from the origin, bringing them back also does not help. i managed to get that under control with TestZBiasFactor setting it far below 1 a value of 0.015625 put it visually back to normal, but that should not actually happen.

It’s a very strange issue. Some days it seems to be worse than others. Or perhaps some forms and orientations. This was today’s issue:

Thanks for the file, apologies on the delay in getting back to you.

I believe the issue is the overall scene extents and the fact you’re focused on a small area. If you select just those objects and run Invert > Hide and then also hide the visibility of the Satellite layer which is locked it fixes the issue here. Do you see the same?

Hi Brian,

Thank you for taking a look at this. Interestingly enough, it does fix the issue, at least until the rest of the objects are unhidden. Do you know why this might be the case? I’ve worked on files very similar to this in the past and not had the problem. My initial thought when this started happening was that I may have selected the ‘Inches - Small Object’ template when I created this file. I’m not sure how to go back and check that, or whether it would have an effect.

Thanks again!

Hi - this issue has to do with the way meshes are displayed and so units do play some role here.
The templates set a unit and a tolerance and you can change both in Settings > Units.
Generally, the use of the TestZBiasFactor command shouldn’t be necessary, but in some cases it still is.
-wim