Closed Polysurface become open mesh

I am preparing a 3d print file, so I tried to create mesh from my 3d object. It was a closed polysurface but when I ‘mesh’, the result became an open mesh. Why would this happen?


Could be a number of reasons, but it generally indicates one or more hidden problems with your closed polysurface that caused the Rhino mesher to create an open object. Often it is due to edges that are actually out of tolerance that have been “forced” to join, or some other geometric anomaly in the surfaces themselves.

If you can post the object here, someone can look. Otherwise, using ShowEdges>Open Edges will show you where the openings are. You can try using the MeshRepair function in Rhino to repair and close the mesh itself, otherwise you will need to investigate the original polysurface to find out why the open mesh is getting created in the first place.


I have the same problem. I have a closed polysurface (no naked edges, no non-manifold edges) but when I export it as an STL-file it turns into an open mesh. Since this is to be 3d-printed it needs to be a closed mesh.

I tried using the MeshRepair command. This gets me from this is a bad mesh to this is a good mesh. However, as I finish the repair, no changes has been made and it still has the same number of naked edges and non-manifold edges.

Since the original object does not seem to have any faults, how should I proceed?

These are the two files:

Well, despite the fact that Rhino says it’s a valid closed polysurface there is a problem area. If you look at the .stl and turn on naked edges you see this:

If you go back to the original and look at the same area, you see this:

Notice that the surfaces which should be shaded (i.e. look solid) are not - they are transparent. Rhino is having trouble meshing the object in this area for the display and as .stl is also a mesh the problem ends up there as well.

There are 3 surfaces that have this problem. I extracted them from the main building and hid it. If I look at their borders I suspect the problem might be this:

Why in this particular spot and only these 3 places is a mystery to me - you have similar joints all over the place. Also Rhino should detect these as bad surfaces and alert you to this fact - but it doesn’t.

A factor in this is possibly the file tolerances you used - 0.01. I prefer tighter tolerances for this type of model. So, what I did was Explode the whole model. Then I changed the file tolerance to 0.001 and ran RebuildEdges on everything.

I then isolated just the three surfaces to fix. I ran UntrimAll (KeepTrimObjects=Yes) on them which left me with planar rectangles and edge curves.

I then re-trimmed the surface with the curves. That seemed to fix the shading problem.

I then showed all of the rest of the model and ran Join. It all joined up into one closed polysurface. The .stl export from it also is closed. (5.3 MB)

Thank you so much!!

I have tha same problem (I think) in another file as well. In that file I cant find any wierd looking surfaces in the original object. But this object has some naked and some non-manifold surfaces. The problem occurred in this object when I did a mesh after scaling the model differently, it worked fine before. Are there any resons for that?

file: object and mesh.3dm - Google Drive