Client not automatically getting Rhinoceros license (+ RhinoGold, RhinoEmboss,Clayoo) from Zoo 6


I installed Zoo server 6 and activated 30 PC lab licenses for Rhinoceros 5 + TDM solutions products (RhinoGold, RhinoEmboss, Clayoo).

The automated installation of Rhinoceros+Rhinogold points to that Zoo server through the following registry key - HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\McNeel\Rhinoceros\5.0\License Manager\Server - which is present on each workstation and populated with the FQDN of the Zoo server

I also created a DNS alias (__mcneel.__zoo5) following the wiki doc
Port 80 inbound and outbound is open on the Zoo 6 server

When I launch my Rhinoceros client (or RhinoGold which uses the same Zoo server), the Zoo server isn’t detected automatically and thus licenses aren’t granted automatically to clients, which is not acceptable since the end users will be students. I want the solution to be totally transparent for them.

The weird thing is that when I launch the Rhinoceros Client and manually test connectivity with the license server (that is prepopulated in the correct field – I suppose this is done by interpreting the reg key mentioned above), the license is granted. See screenshot below

I click on Use a Zoo

The server name is prepopulated. But I have to test connectivity before clicking on Accept.
If I choose “Automatically detect a Zoo server”, it also works (because of the DNS Alais, I suppose) but I also have to test connectivity…

Connectivity is always successful -> I can then click on Accept -> The license is granted
Also, I have to repeat this manual operation for each product licensed on the Zoo server (Rhinoceros -> RhinoGold -> Clayoo -> RhinoEmboss) which is a heavy procedure that must be repeated each time client computers are rebooted (every night !)
Do you know a workaround for this to work transparently ? For the clients to get their licenses automatically ?
Note : the Zoo server is not located in the same range as the Rhino clients but I suppose this is not the issue since connectivity tests with the server FQDN are successful.

Note2: I tested the connectivity between the clients and the Zoo server with Zoo diagnostics and all tests are Ok.

Hi Philippe,

The reason you see the “What do you want to do?” dialog is that Rhino cannot find it’s license file, or it’s like file is invalid or corrupt.

The reason you continue to see the “What do you want to do?” dialog is that, after you answer the questions, Rhino cannot write a valid license, perhaps due to a user right issue.

Does this help?

Hi Philippe,

A couple more notes on deploying Rhino:

1.) Always try to deploy the latest and greatest version of Rhino 5:

2.) Here are some notes on deploying Rhino 5, including information on the Setup.ini file:

3.) Here is how Rhino 5 finds it’s Zoo server:

Note well, as soon as Rhino finds a name of a Zoo server, it stopped looking for Zoo servers. Thus, if a Zoo server name is found in HKEY_CURRENT_USER, it will (try to) use it even though you also have Zoo server names specified in HKEY_LOCAL_MACHINE and in your DNS server. So, choose on method (either Registry or DNS).

– Dale

Hi Dale,
Thanks for your reply and kind support. I observe that licenses are written
under programdata folder. But non admin users only have read access there.
Might this be a problem?
Philippe [short because from my phone :-D)

Yes, maybe. When deploying, though, you can specify the license type via the Setup.ini file, which will create the license file.

– D

Ok. I’ll try this tomorrow. But I’m not sure TDM solutions modules also
populate Programdata during setup. I’ll investigate on this lead. :smiley: