"Check new objects" window is popping up after every command


(Foundafiver) #5

There may have been a bad object but the bug is the fact that “turnoff automatic checking” has no effect.


#6

Well, I was just trying to ascertain if it was coming up up every time because there is a bad object somewhere - which Windows Rhino will also do - or if it was coming up even if there are no bad objects in the file.

Just for the sake of having tried everything, does running the following macro turn it off?

-_CheckNewObjects _Check=_No _Enter

If so, it’s the UI that is at fault, if not the bug is deeper in the code…


(Foundafiver) #7

I will try that next time i encounter the issue. My thought is though that if I have to use a macro to turn off an option that the warning supposedly allows me to do, it is then a deeper problem whether or not the macro sorts it out - does that make sense?


#8

It’s certainly a problem that needs to be fixed. I am just doing some “investigative journalism” to see at what level the problem might be. It might be simply that the command works, but the button you push in the dialog isn’t hooked up correctly. That would be the case if the macro actually works. If the macro doesn’t work either, then the problem is further down towards the core in the layers of software…

–Mitch


(Foundafiver) #9

I’m working on simple things just now so not sure if I’ll incur the wrath of the ‘bad objects bug’ but I’l report back when it next occurs, thanks for you advice.


(Dan Belcher) #10

This seems like a similar symptom: SetDisplayMode command creates bad objects.


(Info) #12

Yes. It seems to be the same problem. I verified with a very simple model with no bad objects.

(I wrote “SetDisplayMode command creates bad objects”)


(Dan Belcher) #13

I’m still unable to reproduce this behavior on my end. Can you please provide a file and simple steps to reproduce this one? (For some users, a full Quit and Restart of Rhino solved this issue).


(Rheajeong) #15

Hi I have the same problem and unable to use software. is there any updates?


(Dan Belcher) #16

Unfortunately, we are not able to reproduce this reliably on our computers. Can you provide a 3dm file and steps to reproduce this behavior? Also, adding your System Information (Rhinoceros > About Rhinoceros > More info… > Copy to clipboard) helps us as well.


(German) #19

Hello,

same here.

This happens always to me at files imported as step with option join surfaces (written from catia). To solve this in my case, I’ve to delete the block definitions. (First explode block, next delete the block definition in block manager.) Then the “checking popup window” was never seen again at my files.


(Wim Dekeyser) #20

Just to make sure, before you delete all block definitions, does the window also pop up for commands like e.g. Length or any of the zoom commands?
Can you post a simple STEP file that causes this behavior on your system?


(German) #21

Yes - I think every command (not changes to the view with the mouse) does have the effect to the popup window. I’ll ask for permission to send you a file or a screen video.


(German) #22

File and video is uploaded.


(Petri) #23

Seconded. The worst part here in my opinion is that pop-up, which gives you the option to switch checking off, but keeps coming back.


#24

Yeah, that’s annoying.

Philip


#25

I also have this issue. I can’t use Rhino like this. Please let me know if we have a solution or if I can help in any way.


(Dan Belcher) #26

Hi Ariel-

Unfortunately, we’ve yet to be able to reliably reproduce this issue on our machines. If you can you provide us with a file and detailed steps to reproduce this, we’d be grateful.

-Dan


(Dan Belcher) #27

MR-3234 should be fixed in the first Release Candidate for the 5.5 update.


(Bendiktorvin) #28

Hi Dan,
Any news on the issue? I am on 5.5.
Imported Step, Blocks exploded and the Bad Object dialog pops up constantly.
“Turn of Automatic Checking” has no effect.
Best
Ben