Changing mm to inch sees no dimension numbers change

drawn a simple house and in mm, default grid occupies a small part of the house. then wish to change dimension numbers to inches. Go properties and choose unit inches and say no to rescale, and nothing changes. Dims still show the mm numbers.

Try again and choose yes and house now minute and the grid is the house size, dims are huge.

How do I get dims to show inches ?

Also is it possible to have them display feet and inches as opposed to 1.75ft ?


Yes if you change units without rescaling, nothing changes except for the property in the file that says what the units are, meaning the sizes of the objects are changed. If you do rescale, everything gets scaled so that the actual size remains the same.

Units has nothing, though, to do with just adjusting the size of the grid, that’s what the Grid settings are for.

You don’t have to change units to display feet-inch dimensions, you can enable that in the properties for your dimension style.

Hi Jim,
aha, selected feet in properties for my dim style and object remains same, grid size fremains same, dims size remains same…just what I wanted.

If I wanted to change project units to feet/inches, lets say I had some imperial plans to work with after having worked to metric, I would choose units>feet in properties >units, and then choose rescale at the prompt ? My house would remain same size.

Why however did the house shrink massively relative to the grid and dimension arows and numbers, latter made it a total mess, couldnt see the house for the dimensions !

…or is it that if such a scenario came along of the imperial plans, would it be necessary to change units or just enough to change dim units in properties to work with them ?

I have always thought that to enter imperial values one needed to alter main units property to imperial. saw the rescaling option and decided not to mess up and grabbed the calculator instead !


The house shrank because you changed your model units. A wall that was 3000mm would be 3000’ if you didn’t scale. In order to get that wall to be 9’-10" and change you need to scale the model down so what was 3000 units is now 9.84252 units (if you are modeling in feet, 118.1102 if modeling in inches).

You dimensions ended up looking massive because they are still using the unit settings they are picking up from you dim styles. So if you had set your text and arrows up to be 3mm tall, when you change you model to feet, they will now be 3’ tall.

For you last question, you do not have to change the units if you are outputting to a different unit system, but it is highly dependent on the situation. If you are building a house and say only one trade wants drawings in metric, but everyone else wants drawings in imperial, it would make sense to keep the model in imperial units and just use a different dim style for that one drawing (or include alternate units for everybody). If you modeled it in one unit system, but then found out that it is being built elsewhere and everyone will be using a different unit system than you, probably best for you to change units.

Rhino is pretty good about mixing units as well. For instance if you are building your house in imperial units and thus have your model in inches, but have one piece of hardware in millimeters, you can draw that piece of hardware pretty easily using the proper suffix on the command line. So if you call line, pick your first point, then for your second point enter 1000mm, you will get a line that is 39.37".


Cheers Sam,

All now understood and mentally logged.
Is there any way to get the dimensions to auto scale display wise if one chooses scale ?


If you change model units, you will have to also change the named dimension style setting because they are based on the model unit setting from the initial template file.

If you change horses in the middle of a stream, there’s a little effort involved and a fair amount of splashing to be expected.