Altering units to inches from mm asks to rescale model but why?


#1

Hi,
I have never understood why when electing to have units as inches when currently units are mm, I get asked if I wish to scale the model by 0.393701

If I reach out for an inch ruler in my metal toolbox when I was using a retracting mm one my object is still the same size.

I was working on a scale item for modelling, but have decided to blow it up 76 times to full size.
I enlarge it scale3D 76, its now full size.
The original was created in inches back in the 1930’s so it makes sense to make the parts to nice neat whole inches, 4.95 inches for a wheel is obviously 5 inches.

I go properties and select units inches and get asked do I wish to scale model by 0.393701

Confuses the pants off me.

Do I tell it yes or no ?

If a cube was 1ft x 1ft x 1ft I wish it to still be that size, I see no point in it being 0.39" x 0.39" x 0.39"

Also is there an option to have the dimensions text etc size also scale up as now I cant see them.

Steve


(John Brock) #2

Rhino is asking if you screwed up or not, and trying to be nice about it.

If you drew a box 10x10x10 and you thought it was inches but turned out it was millimeters, when you switch Units, you would say no, you don’t want to scale it because you still want it to be 10x10x10 when in the new unit system.

If you knew you drew the box in mm and you wanted to switch to mm, then you would say yes to the unit change because you want the box to be the original drawn size.

Make more sense now?


#3

actually no !

If you knew you drew the box in mm and you wanted to switch to mm

If I was with units mm and drew a box I cant see how I would be then wanting to be switching units to mm.

In my case I have drawn over plans/photos that are 1/76 scale, units were set to mm.
I enlarge everything up 76 times to get it full size, and wish to work in inches now.

do I say yes or no to that scaling of 0.393701 ?

I had e.g. a cube 4.0105mm each edge and now it should be 12inches each edge after scale3D 76

If I was to export it as stl and say go mill it, I would want to see a 1ft x 1ft x 1ft cube with the machine taking the stl file and working to it without any human alteration of scale.

do I say yes or no ?

Also if I say no to scale then place a dimension I get 138 when I expect 5 for the wheel. Dimensions offers millimeteres small or millimetres large, it doesnt now say inches small or inches large, do I have to create inches options and convert all the millimetres dims I have placed to inches ?

I have tried for No then pasted a 1ft cube from a rhino inches from first created project, into the scene and its minute, so it must be yes I need to rescale when altering units to inches after scaling it up 76 times.
This is alien to my way of thinking.

Now the dimensions are still visible, thats good ! yet in properties they are called millimetres, whilst in the project started as inches they are called inches.

Cheers

Steve


(John Brock) #4

Sorry, I can 't follow all that.
Your question has changed.

Basically if you drew something and you THOUGHT you were in a different unit system than you were, when you discover the mistake and change the unit system, then you would say NO, don’t scale the geometry.

If you did NOT make a mistake and just wanted to change unit systems, then you would answer YES.

BTW the scale factor you listed is 1/2.54, or the CM to IN conversion
An object 1" long is 2.54 cm


(David Cockey) #5

@Steve1. When Rhino scales an object it scales all the numbers used internally to describe the object. A cube which is 1 unit long when the units are inches will be 25.4 units long when the units are millimeters. So if you change units the object needs to be scaled unless the units specified were wrong.


(John Brock) #6

Or…

No - Leave my numbers the same
Yes - Change my numbers to the new unit system


#7

Hi,
In summary, if I havent made any mistakes and wish to be working in inches when originally I was working in mm, I need to say yes to the rescaling prompt.

I have now done that. The dimension text size is now visible.

One way of checking its the right decision was to create a new project in inches, create a 1ft cube and copy paste it into my units altered project, it looks to be the right size relationship to items already there.

I was saying that although I am now units inches the properties>annotations>dimensions still offers me millimetres.
However if I had created from new an inches units project I would be offered dimensions called inches small etc.
I wish the names of the dimensions changed to reflect the fact that I am now placing dimensions in inches and that the existing dims are now displaying inches.

help…I cant see this post in ‘windows category’ can someone move it there ? I cant see how to.

Steve


(John Brock) #8

If you change your Unit system, you’ll most likely have to modify your dimension styles, grid settings, snap spacing, etc. to get everything sorted and looking as expected.


#9

Hi,
I sometimes have been on site measuring in mm and inches and its easier to alter units than start converting mm to inches and vice versa, but if I have to mess around to that degree then no.
I still though am baffled why dimensions says millimetres in the properties>annotations options when I am now in inches.

and can this be put into windows section of rhino ? The only way I can find this thread is via a link I saved to it.

Steve


(John Brock) #10

Assigned to Rhino for Windows category.


#11

What’s going on as I understand it is that a Rhino “unit” remains constant. If you draw a 10x10 square and your units are set to mm you get a 10mmx10mm sq. If your units are set to inches you get a 10"x10" square. The problem comes when you want to change units. If you then change from inches to mm and say NO to scaling your 10"x10" square will now be 10x10mm, not 254x254mm as it would be in real life if you just changed rulers! Stupid, I know, but here we are. Same deal in AutoCAD as well.


#12

What’s the specific problem with that? The units are just a label–well some CAD systems used to have a hard-coded, fixed model scale kept hidden from the user–so yeah if you change unit systems the model has to be rescaled to keep the size the same.

Most of the time that’s what you want to do if you switch units, but sometimes not–some crappy file formats still widely used for data exchange don’t actually say what the units in the file are–so that’s why they ask. I mean in V6 they started doing this scaling without asking when copying and pasting between Rhino sessions, and people complained.

Of course it’s not necessary to actually switch model units to take measurements, enter distances, or (with some extra work depending) use dimensions in some other unit system, which is good since you don’t want to do that willy-nilly, if you were to rescale many many…many times you would eventually have distances change due to rounding errors in the scaling factors+translating to and from Base 10.


#13

It’s seems that having to scale the model when you change units is unnecessary and lazy on the part of programmers. Just change the units and not the model – like real life! I’ve been fighting this battle for 30 years and long ago realized I’m just pissing in the wind.


(Pascal Golay) #14

Hello - say you make a cube 1 inch to a side, and oops, you meant to be working in mm. Change units. Do you want the cube to be 1mm or 25.4 mm when you’re done?

-Pascal


#15

So you want the model to be stored in some separate hidden unit system that’s totally separate from what you have set in the interface? Some products do that and it works alright as long as your models aren’t very big and you aren’t picky about tolerances, if you’re pushing either of those things then the actual numbers that are being stored do matter for the quality of the geometry because the precision of those numbers and the precision of operations done on them is not unlimited.


#16

What I want is to draw a 10” square then change units to mm and have the program figure out that the square is now 254mm without having to resize the model. If I physically cut a 10” square of paper all I have to do is change my ruler to get the size in mm, I don’t need to change the piece of paper.


#17

Unlike what you think is real life, the model does not actually exist. All that exists are lists of numbers. There is nothing else but numbers.
When the user changes the units the software has to go through the lists and change most of those numbers. If you want all those numbers to not change when you change units then you respond with “No”

If you hit the “No” button then the only number that gets changed is the one that represents which unit system is being used.

The reason you assume the size of the model has changed when the square changes from 10 units to 254 units is that the things you use as reference for size don’t get changed. The grid numbers don’t get changed. the tolerance numbers stay the same. The screen to geometry transformation doesn’t change. If your frame of reference was changed along with the geometry you wouldn’t get the impression that anything had changed.


(John Brock) #18

To extend your metaphor…

If you drew what you thought was a 10" square (but was really mm), when you discovered your error and changed your units from mm to inches, you would NOT want to scale the box.
You want it still to be 10 units when you’re finished.


#19

That’s a different issue. If I get a model from someone, a Canadian say, built in mm, but I, being a metrically-challenged American still using inches, shouldn’t need to change the model, just the units.


(John Brock) #20

Okay, I tried.