Change linetype keyboard shortcut?

Is there a way to create a keyboard shortcut to change a curve linetype from solid to hidden? I find the current method a bit tiresome (select line>go to properties>dropdown menu for linetype>select hidden).
Would also love such a shortcut to change layer of a selection.
Id love to program a hot key (macro) into my razer stream controller.
Thank you.

Hi Peter - a macro like this

! -_Properties _Pause _Object _Linetype
_Object _Hidden _EnterEnd



wow that was fast!!! Ill test it now and report back.

almost worked, just had to delete the underscore before Hidden. Now works. This is great! Thank you. :slight_smile:

Now Im trying to create a similar hotkey for changing an objects layer. I’ve tried editing this various ways but keep getting the error “unknown commend 0.13”. I have a layer 0.13.

These dont work:

! -_Properties _Pause _Layer _0.13 _EnterEnd
! -_Properties _Pause _Layer 0.13 _EnterEnd
! -_Properties _Pause _Layer “0.13” _EnterEnd
! -_Properties _Pause _Layer _Select 0.13 _EnterEnd
! -_Properties _Pause _Layer _Select “0.13” _EnterEnd

Hi Peter - sorry about the extra underscore - your layer macro has the same problem in the layer name. Put layer names inside double-quotes as well - or any text that you use in a macro - so that spaces can be included without triggering an Enter at the command line.’

! -_Properties _Pause _Object _Layer “0.13” _EnterEnd


1 Like

Thanks Pascal. This worked but I had to remove the quotation marks around 0.13. Thank you so much!

Hm - that seems incorrect - @PeterB can you please try typing them - the quotes - right in Rhino? I tihnk Copy/paste from Discourse messes with this character somehow.


Typing the quotations does work now (versus copy/pasting).

However, this same shortcut command does not work when I try to set it for a word layer (HATCH, in this case). It tells me “Multiple layers are named “HATCH”. Enter full layer path.” Not sure what to do here as I only have one layer named HATCH.
Screenshot 2024-05-28 100222
Screenshot 2024-05-28 100250

Hi Peter - that looks like a bug to me, I’ll check it.



I changed the layer name to HHATCH and it worked. I think it’s confused by the fact that I have several layers with the word HATCH as the prefix.

@PeterB - can you please post or send to a file with layers named so that they do not work with the macro? The file can be empty… So far my quick tests work so there must be a detail I am missing.


Here it is
hatch_not_working.3dm (189.0 KB)

Hi Peter - thanks… cannot seem to repeat this

this works for example - is that what fails for you?


Yes, that does not work on my end. Using Version 6 SR35 (6.35.21222.17001, 8/10/2021). But the workaround of adding an H solved the issue.