Change in Grasshopper PolylineCurve Loft outcome between Rhino 6 and Rhino 7

Hi all, some of our students found this difference between Rhino 6 and Rhino 7. Is it a bug or a deliberate change? It certainly means some scripts no longer work.

GHScript:
SurfaceVsPolySurface.gh (21.6 KB)

In Rhino 6:

In Rhino7:
SurfaceLoft_Rhino7

1 Like

Hello - I get a single surface from the Loft here, in V7. The Loft options need to include Rebuild, which is set in the GH you posted.

-Pascal

Hi Pascal. That’s very strange. The rebuild command doesn’t seem to change anything for me. Could any of this be related to tolerance? I’ve just tried making sure I’m fully up-to-date with the latest service release candidate and I am… yet I still get the polysurface.

Hello - I mean the rebuild option in the Loft component-

which IS set in your GH so ought to make a single surface - it seems that is being ignored in your case but working here… Can you confirm that with another simple GH with a Loft from polylines?

-Pascal

Hi @pascal it does seem to remain an issue between Rhino6 and Rhino7 for me. See attached. Also have checked this with some colleagues and students and they get the same behaviour as me.

Rhino6:


Rhino7:

Thank you for doing QA work that McNeel missed before releasing R7.

@Joseph_Oster I take it you see this problem as well then?

-Pascal

I don’t have R7 and am in no hurry to upgrade.

@jjsolly - this bug is in 7.1, 7.2 and not, as far as I can see in 7.3, which ‘in-house’ builds I have been running.
I’m checking on this now.
The release candidate for 7.3 should become available tomorrow - in Options > Updates and statistics, set the update frequency to ‘Release Candidate’ to get this build.

-Pascal

1 Like