Caping problem


#1

I thought if I split a brep with a flat surface, it can’t be a probelm to be capped. But this is not the case.
What is the solution?
caping problem.gh (9.8 KB)
capping problem.3dm (1.4 MB)


(Vanessa Steeg) #2

Hi @Balazs - I believe the problem is that the Split component requires two Breps (polysurfaces) to accomplish the task. In your example the “cutter” object is a surface. Try extruding that surface into a box and re-referencing it back in the C input.


(Matt Gaydon) #3

Hmm so i made a box in Rhino and split it with a planar surface to test @Vanessa’s answer as though i had used surfaces before and it worked (see example)

Then opened your file and in Rhino trimming the hole and capping worked so I looked at the grasshopper which seemed to be even more broken on my machine. Invalid Breps not even Open Breps, then I notice the code was not near the top corner and as I tried to zoom the corner of the canvas it failed so I copied and pasted the code into the corner of the canvas and it works fine now. EDIT: Just reopened it and it works in the original location on the Canvas.

Anyhows here’s a working version near 0,0 on the GH Canvas.
caping problem - Solved-MG.gh (4.4 KB)


#4

Hi Vanessa,
it is jut one element of a large system. The split has worked in the previous 30 cases. And it was cut always the same flat breps. So I dont think it has to be polysurfaces.


#5

have you opened it in grasshopper 1.0 (meaning rhino 6) ?
Maybe the Cap was rewritten. That is why it worked for you.


(Matt Gaydon) #6

Yeah opened in Rhino V6 don’t have V5 on this newer machine. Hmm not heard of cap being rewritten between version and there is no legacy version of cap in GH. Though maybe the main cap code has been updated. Does the version i attached not work in 5 then?


(Vanessa Steeg) #7

Ok, it did solve the problem on my end, I no longer got the message Invalid Brep. But again, that’s why I started the phrase with “I believe…” ;-).


#8

No, I have moved it near 0,0 as you said still does not work.


(Matt Gaydon) #9

hmm, maybe someone with Rhino V5 can shed some light on why its failing then as i can’t break it here after i moved the code. Or reopened the original file. Odd.


#10

thanks, anyway.


#11

Idea anyone?


#12

This could be another way.

caping problem_re.gh (244.6 KB)