Can't load Github example files: i/o error

Rhino 7 Windows latest Release

when i try to load any examples files from here:

I get this error:

any idea what could be causing this?


Hi @dk2079

That’s odd. Can you name a specific file from there where you are seeing this error?
and which exact Rhino version are you on? (you can check in help>About Rhinoceros)
Are you seeing the Kangaroo components tab in GH? getting any errors on startup?

Hi Daniel,

thanks for catching up so quickly!

I am on Version 7 SR26
(7.26.23009.7001, 2023-01-09)

I have tried with many files, none have worked yet. These I tried (squishycurves and kangaroo_Test2 are not from Github)

The others in that folder do work (squishycurves and kangaroo_Test2) I just downloaded something to test from here: CurveCollide: getting duplicate polygons in Kangaroo solution - #4 by lauren1

I do get one error on startup related to scarab (legacy maxwell material plugin)

don’t think that matters though…

Command: Grasshopper

An error occured during GHA assembly loading:
Path: C:\Users***\AppData\Roaming\Grasshopper\Libraries\Scarab.gha
Exception System.IO.FileNotFoundException:
Message: Could not load file or assembly ‘Maxwell, Version=, Culture=neutral, PublicKeyToken=0c67436bca449732’ or one of its dependencies. The system cannot find the file specified.

and yes, I can see the Kangaroo2 tab, and I also have legacy Kangaroo installed:

So when you open for example, this file (22.4 KB)

are you saying you get that error shown in your first post above?

no error. that file you posted works fine.

Also I can load the ones from here without problem:

How are you downloading the files from github?

1 Like

yeah… that is it: :person_facepalming:

thank you :pray:

I always did right-click save as… looks like that didn’t do what I expected.

I just compared the content of the two files:

the file i downloaded contained:

No problem. I see how the confusion can happen - the filename on the github page and mouseover text says, but it’s actually a link to the github page for that file, not the download link for the file itself.

The easiest way is probably to use the green ‘code’ button on the main project page and pick download zip from the options then unzip that folder to get all the gh files without having to download them individually.

exactly that.

the hint to the .zip was very helpful