Cannot see extruded shape in shaded view, only original curve

Pool detail.3dm (54.5 KB)

Seems to be working here (Windows, no Mac here to test today)

You are however a bazillion centimeters from the origin. Generally things work a lot better if you are closer…

–Mitch

I copy and pasted it from a specific position in a DWG file, for some reason the origin is always miles from the original DWG origin. Here is my Artistic view, Shaded view and Rendered View



Uploading…

You can copy and paste directly from AutoCAD to Rhino?

If you move the extrusion to the origin, does it shade correctly?

–Mitch

Moving this piece closer to 0,0 allows it to be shaded:

Hey Mitch,

I don’t use AutoCAd, I import all the DWG and DXF into Rhino. I copied some of the curves from that file and redrew and added, curve booleaned them, made sure it was a closed curve and then copy and paste into new file, miles from origin and unable to see the shade…I will try moving it now.

Guys thank you so much, moving it to the origin fixed it perfectly. You are life savers. Thanks again! this has plagued me for years working with architects and engineers CAD files.

This is what I don’t understand. Are you sure that the curves weren’t already miles away from the origin in the original DXF/DWG? When you copy/paste geometry from one Rhino instance to another, the geometry does not move, so it shouldn’t “suddenly” find itself miles from where it was in the other file. Something else is likely going on.

–Mitch

It is not a requirement that you model close to 0,0,0, but in your case, you were 55 billion units from origin. There are display anomalies which aggregate as you move away from 0,0,0. My suggestion is to ensure your units are correct after you import the drawing. If you are still such orders of magnitude away from 0,0,0, consider modifying the position of the object.

I import files that have come from Autocad. The origin is always miles away in Rhino. I just leave it usually, so yes when i copy and paste again inside Rhino it goes to the same distant origin. Always the same with DWG files. I am just opening them default. Should I change a setting initially?

The scale is always different to the original. I know when I export the DWG back for them to open they have the reverse problem, they can not find the object at their origin, so I try and leave the scale and the origin position, hard for me easy for them.

Sounds like some equivalent of ModelBasePoint is set way off in space in the original application.

-Pascal