Cannot open new Rhino window: "Contacting McNeel server"

bug
unhandled

#1

Hi. A bit frustrated here as I got projects for clients to finish and I cannot open Rhino. I get this window and it’s not going away:
Capture2
If I press “x” or Cancel it brings me to this window:


When I click on “login as siemen” it brings me to the contacting mcneel servers window again. This is pretty messed up. I would try restarting my computer if it wasn’t for the fact that I still have another Rhino window open with a project I’m working on at the same time and I don’t want to risk not being able to work on that either.


License expired
URGENT Rhino 6 will not start - Stuck on "Retrieving License from Manager"
#2

After 25 minutes of waiting I get this:
Capture4


#3

I got that this morning when I opened my laptop (at a client’s place) and it hadn’t run Rhino in several weeks. I got on their wifi and had to go through the log-in procedure, pressed the log-in as Mitch button and got an error message - but Rhino opened anyway and I checked in Options - it had gotten the license… (didn’t get the last screen)

I did notice a message yesterday on my work machine that I had been “logged out” of my McNeel account even though I hadn’t done anything.


(John Brock) #4

Hi
I suspect Windows is confused about what your default browser is and needs to be kicked in the head. Rhino is asking Windows to open a browser window and Windows has gone deaf.

It’s easy to sort.

Press your Windows key and run Settings.
Select “Apps” and then “Default Apps”.
Click on your Web browser. Choose a different one then switch back to what you want to use.
Then when Rhino asks Windows to launch your browser so you can login, it will actually launch a browser.

Any luck?


#5

This doesn’t seem to make a difference…

That is to say, if I did it correctly. I tried following along your steps but I’m on Windows 7 so I’m assuming you mean “Control panel” with “Settings” and “Set default program” instead of “Default Apps”.


(John Brock) #6

We mostly see this on Windows 10 so those are the details I supplied.
Can you open your browser and visit:
https://accounts.rhino3d.com/?controller=home

Then click on Licenses and see yours?


#7

Yes


(John Brock) #8

Did you try changing your default browser, or did you just open the tool and verify it’s the one you want?

The fix is to actually change it so Windows updates it’s settings, fixing the problem.
Then you can switch back to your preferred browser.

At least that’s how it’s worked for everyone else including myself.


#10

I tried changing the default browser to internet explorer then start Rhino: no succes. I tried changing the default browser to Firefox then start Rhino: no succes.


(John Brock) #11

I’ve assigned this to the developer @aj1. When he gets in I’ll ask him to have a look for more help.
I’m out of ideas.


(Andrés Jacobo) #12

Hi @siemen can you try the following please? It is important you follow the steps verbatim.

  1. Open Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. Click the Advanced tab, and then click the Reset button.
  4. On the Programs tab, under Internet programs, click Set Programs, then “Set your Default Programs”, select Internet Explorer and click “Set this program as Default”.
  5. Click OK and close the dialogs.
  6. Launch Rhino and try again.

Let me know if this works for you.

AJ


#13

Hi Andres,

I followed your steps but it doesn’t seem to have fixed the problem, unfortunately…


(Andrés Jacobo) #14

Hmmmm, that’s unfortunate. Do you have any anti virus software running on your computer?


#15

I do! Good point! I’ll check if turning that off solves it.


#16

Nope :frowning:


(John Brock) #17

Another long-shot idea…

Any chance Windows has installed an update and is waiting to reboot?
Run Windows’ Check for Updates and see.


#18

You might be on to something. The shut down button has a warning symbol next to it saying it will install updates. I’m almost finished with the Rhino file which I still have open, After I’m done I’ll try this out and see if that solves the issue.


#19

It worked. Windows update was causing the issue. Thanks for helping out


#20

Seems like something similar is happening now after restarting.
180330%20Capture
I’ll restart again and probably that will fix it. But it is a bit annoying, this wasn’t a problem with Rhino 5?


#21

Yep. You get logged out of your Rhino account automatically every 90 days (or so), so this will happen every few months from now on. Of course this did not happen with V5, as there was no online licensing function.

— Mitch