Cannot import rhino files from drive, Dropbox or via email


Please help or i would like a refund


Hi @Harry_Mazzarolo, this is how it works on my iPhone.

I open app then click + to add new model.

I work with dropbox, so i choose that option, I am already signed in.

I navigate to my folder to choose my model.

My model is now added to the library.

I now open my model to view it.

IHTH «Randy


Hello I appreciate your tutorial, but I know how to use it. When I try to link my google drive, to which I have an abundance of rhino models in organised folders for university, it says I need a secure connection? Tried home wifi, 4g, uni wifi, friends wifi. Doesn’t work, saw someone else came here with the same problem and I tried sending the file to my email and opening it like that, but I am not given the option to open with Irhino 3D upon downloading the file. I then went to the effort to download Dropbox and upload the file to that. After 40 wasted minutes not one of these methods worked even after multiple tries and redownloads


@Harry_Mazzarolo that’s a drag. I am assuming you can get to the Rhino files with the Google Drive app. I will check on my iPad later at home. It works great for me showing files to other people.

Any ideas @dan ?

(Dan Belcher) #5

This is a drag. It sounds frustrating. I don’t know what is causing this and I cannot seem to repeat it on my end, which makes me believe it might be region or locale-specific. Regardless, the APIs and integration with cloud services (GoogleDrive, Dropbox) in iRhino 3D is getting out-of-date fast. Mobile application development moves at light-speed. I have had reworking cloud integrations on my list for quite some time, but have not managed to get to it yet. This is cold-comfort to @Harry_Mazzarolo, however, I’m certain of that. The Dropbox one is confounding, because it is working perfectly for me and all devices I have access to.


Hopefully a fix comes soon to provide me and others justice for the money spent. Here are some pics to illustrate my dilemma


I’ve read elsewhere that it could be something to do with ios9. Has anyone else had issues using the program after installing onto iOS 9.3.4?


I don’t remember, I am running iOS 10 bets. It looks like the authentication issue is with Google, not Rhino, from your screenshot. Something in settings?

(Dan Belcher) #9

Hi Harry-

I am seeing a lot of exceptions (“errors”) coming from our Google Drive client that look like this:

[GoogleApiRequestException: Google.Apis.Requests.RequestError The domain policy has disabled third-party Drive apps [403] Errors [     Message[The domain policy has disabled third-party Drive apps] Location[ - ] Reason[domainPolicy] Domain[global] ] ]

Translated: these errors are caused by a domain policy not allowing third-party apps. Who manages your Google Drive account? Is it part of a Google Apps for Business account? All of our accounts are managed by Google. I checked our domain policy and we allow third-party apps. So, if your account is managed by Google, you would need to find out who sets the policies. Either way, I need to provide a better error message (IR-514) for those people who are not allowed by their company to use third-party apps. Again, it is mere speculation right now, but I have a hunch this is what is going on.



I remember having an issue when our work emails were controlled by Google, I couldn’t make a G+ account with it, because it didn’t allow 3rd party apps. Sounds like it could be Harry’s issue.

Thanks for doing this lost leader work, I appreciate the iOS app.


App transport security policy...say what?

I’ve tried installing irhino on an iPad to which I was able to link my google drive with no errors. Yet similarly to on the iPhone (6+) no documents or folders pop up. For some reason irhino doesn’t even appear as an option for opening the file from email. Spewing because nobody else seems to be getting these errors, but I’m hopeful to find a solution as this would greatly benefit my studies


My google drive is managed by my university

(Dan Belcher) #13

Thanks for checking on this. I suspect they have a policy that prohibits third-party apps integrating with Google Drive. Regardless, we need to provide better feedback and fix some other bugs to make it easier to get your 3dm files into iRhino 3D. Thanks again for reporting this and for your patience.



i am also having the same issues , I load a model into my drop box but it does jot show up in the iRhino app . Also if I try to open the file in an email it does not give me irhino as an option to open with , I think I used to do it this way .
And I know for sure it used to be easier for this to work as I use de to use it with customers , so they could see the model , now I can not use it anymore , as neither I or my customers can get file loaded through drop box , google drive or email.

Any help out there ?

(Dan Belcher) #15

I have seen this happen a couple times as well. I presume you have tried logging out of Dropbox and GoogleDrive and trying again.

At the moment, when I have seen this crop up, the only solution that has worked for those users is deleting reinstalling the iRhino 3D app (not ideal).

We are in the (very slow) process of completely revamping how cloud storage systems - like Dropbox - are integrated into iRhino 3D. Dropbox is actually discontinuing the system we are using in iRhino 3D this year, so we need to renovate this anyway.

I’m sorry for the bugs you are experiencing with iRhino 3D.


It is not such a problem for me as I have the full rhino package , it is more of an issue for my customers , one of whom just purchased Irhino by my request , and can now not get the model I made him for viewing into Irhino .

(Dan Belcher) #17

In this unfortunate situation, I would suggest reinstalling iRhino 3D (deleting the app, then getting it again from the App Store). I’m unable to reproduce this issue, and I have tried. I have opted instead to completely rework the way cloud integrations work with iRhino 3D, which is something that needs to be done sooner rather than later.

I wish I had a better answer.


I am having exactly the same issue on either an iPad 4 and IOS 10.3.3, or my iPhone 6S with IOS 11.0.3.
Very frustrating not to be able to access the Google Drive and alternatively, it would be functionally useful to start Rhino by clicking on the model attached in an email.

I have reinstalled the app on both devices.

(Dan Belcher) #19

I will look into this more. Unfortunately, I’m not able to reproduce this on my side. I suspect it has something to do with regional or organization-specific drive settings.


I dont understand your response. There is no “organization” managing the drive settings and as for region, please explain. The files in question are 3D laser scans, scanned in Canada by a Canadian user, stored on a google drive in Rhino compatible format with permissions to that drive granted to another Canadian user of Rhino 3D on an ipad running IOS 10.3.3, subsequently updated to IOS 11.0.3

Thank you