Cannot add structural column to Revit

Hi there,

Seems like I can’t create or modify structural columns at the moment.

Rhino.Inside Revit: 1.22.8906.14842 (2024-05-20T08:14:44)
Rhino: 7.36.23346.16351 (Rhino 7)
Revit: 2024.0 (24.0.20.20)

I have also tried this on the daily build (1.23.8907.21534) and I had the same error.

It seems to be particular to only concrete columns.

Thanks in advance!

A little newer version of the Rhino and RiR version are looking OK.

@Japhy @kike

I was assisting on project and been facing a similar issue but with a different component, “Host Shape” when trying to add points to a floor.

I have tried with the below versions with revit 2022 and one time with revit 2023, with no luck… any prompt suggestions would be of great help.

Below is a sample I setup for your convenience.

image
image


RiR_Components Error.gh (11.0 KB)

Thanks, I’m seeing this as well.

If possible, do you have any previous versions download links that might have this working?

Sure thing, I’ll start rolling back and let you know what i find out.

1 Like

I did a bit more of checking because i remember I was using it on a different project couple days ago and it was working fine… but in the other project I was only working with corner points of the floors.

As shown below when the point in the middle is in plane they get added fine in revit, and once it moves out of plane it gives the error, hope that might help.

RiR_HostShapeError

1 Like

Thanks,

Looks like we are good in 1.20.8836.21283, sending a link shortly.

1 Like

There is a fix for this on v1.22.

We will release a hot fix for 1.20, 1.21 and 1.22 about this one tomorrow.

3 Likes

Hi all,

thanks for the help.

Can confirm, for the problem that I was facing, 1.23.8913.17388 works

Thanks @kike.

Just sent our IT to update all computers with the latest daily build which is working.

1.23.8913.17388 - Daily Build

Regards Chris Pires