CAD Exchanger Import plugin for Rhino

In collaboration with the Rhinoceros development team, CAD Exchanger launched a plugin that directly imports 25+ CAD formats into Rhino.

Its scope includes, but is not limited to, several neutral (JT, Collada, IFC), kernel (ACIS, Parasolid), and native (Siemens NX, CATIA, SOLIDWORKS) formats.

Download an eval on food4Rhino…

Posted Feb 05, 2021 by Carlos Perez on Rhino News, etc.

I saw this in the mail Rhino sent out today… but how much does it cost? It doesn’t say anywhere that I could see. It just says “trial” on the license and on their website, they just talk a lot and mention services, so no straight answer from there either…

Clicking through to their site via food4rhino has a pricing section. Did you check that?

1 Like

I did not. I clicked on the link in the middle of that page, because I didn’t see the small “website” button, and that took me to their general site where I was utterly lost!

Thank you for pointing that out! :sweat_smile:

(Very reasonable pricing, imo… but again, to put it in perspective: It’s a plugin that costs 60% of the price of Rhino, for a small convenience factor… isn’t it time to raise the price of Rhino, or at least add some often requested features behind a higher priced tier?) :smiley:

It does not work with Catia files here. When I try to open or import .catpart or .catproduct I always get an error message:

A problem occurred while reading the D:****.CATPart fileThe trial expires in 18 days

Then I tried .stp format and got a single closed polysurface what should have been hundreds of closed solids.


Ha! Yeah, so I tried it on one of our large scale production assemblies in NX and got this:

How do I uninstall a .rhi file? :joy:

EDIT: Tried it on a smaller consumer product assembly as well… instant crash there too. :bomb:

Then I tried it on a single part, and got the “a problem ocurred” thing.

What a piece of junk!

Best to contact the developer directly.

You can uninstall it by removing the RHP. Tools > Plug-ins, select the plug-in, click on Details… and then the location link. File explorer will be opened at the location of the RHP file. Close Rhino, remove it and restart Rhino.

I also got the crashes and send an error report with the file information. Maybe it can be forwarded to the developer… If there is interest to improve this plugin the developer may contact us.

Finally it succeeded to convert a .catpart but also everything was just one object. All meta data like hierarchy, blocks, naming and so on was lost. Unfortunately this is pretty useless for me :frowning:

Hello Folks,

Sorry for your undermined experience :frowning:. (As usual angry users speak louder than happy :wink:)

CAD data exchange is often extremely challenging, so issues are possible, I have to admit. Some formats may have current limitations (like range of supported CATIA versions). STEP should be fine so I particularly regret about the STEP-related bug.

I and my team would appreciate reproducers - files that provoke those issues. Best of all would be to send files via WeTransfer or alike to support at cadexchanger dot com and send some accompanying info. Thanks to all who already recently did that :handshake:

We will try to periodically monitor this thread but direct emails will always be preferred. We make public releases four times a year and enhancements and bug fixes are always included. So please do check in even if this current version is far from perfect.

Thanks again!
Roman Lygin
(Founder and CEO, CAD Exchanger)

Hi @roman.lygin ;

Thanks for listening! I’ll send you something…


Thanks Jess, received!

You’re welcome @roman.lygin ,

The price of your plug-in is really reasonable. I’d love being able to directly exchange all these file formats directly from inside of Rhino! The quality of the NURBS geometry looks promising, so I hope that you’ll get over these initial quirks. Let us know if there is something new to test.

Good luck and best regards,