Bug when using the ClippingPlane. The preview, when creating objects, is not working

clippingplane

#1

Also the help lines that usually show up when snapping on distant objects are not visible.


(Pascal Golay) #2

Hi Bogdan - if I have a clipping plane in place and active, if I make say, a box, so that it is partly clipped, the preview/feedback while making the box is clipped - is that what you mean, and if so, is that good, or bad?

-Pascal


#3

Hi, Pascal.

No, what I mean is that I don’t see the box at all until i finish it. There is no preview/feedback at all, it is like drawing blind.
This problem is very easy to notice. So the fact that you don’t see it makes me think that it might be something related to the graphic card…


(Pascal Golay) #4

Hi Bogdan - thanks, we are seeing the same thing - the preview/feedback is clipped, and you think it should not be - that’s what I wanted to know…

-Pascal


#5

The preview should be clipped I think. But there is no preview/feedback at all for me right now


(Pascal Golay) #6

Ah, OK - so, if I understand, even if the entire box is being made on the visible side of the clipping plane, you do not see any feedback? That does sound like maybe a video card thing…

( I could see a case for not clipping the preview/feedback at all, which is what I thought maybe you were suggesting.)

-Pascal


#7

Even if the entire box is being made on the visible side of the clipping plane, I do not see any feedback. And it is the same for curves or anything else.


#8

And I still see this problem:

Which might be a video thing as well. I’ll check on another computer.


(Pascal Golay) #9

Hi Bogdan - can you post the output from `SystemInfo’? thanks.

-Pascal


#10

Here it is:

Rhino 6 SR0 2017-8-22 (Rhino WIP, 6.0.17234.9201, Git hash:master @ 1f5b7d29aeb207bcc90ac6a5761c3a3760fb21ce)

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)

GeForce GPU/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.33)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino WIP\Plug-ins\NamedPositions.rhp “Named Position”


(Pascal Golay) #11

Hi Bogdan - this makes me a little suspicious… @stevebaer - can we infer anything from those 'NA’s about the driver being recognized etc?

-Pascal


#12

If there’s of any help the driver is:
NVIDIA, 5/17/2017, 22.21.13.8233, Microsoft Windows Hardware Compatibility Publisher


(Wim Dekeyser) #13

FWIW, I can also provoke a completely hidden geometry creation on the visible side of the clipping plane:

Screenshot:

The big box in the center is clipped by the CP. As you see, the crosshairs are being clipped on the visible side of the CP. When the Box command finishes, the box appears but while drawing it, all is hidden.

Earlier today, I somehow did the opposite. I was able to create an object with visible feedback but when the command finished, the object was clipped. I had to check in other viewport and then saw that it was indeed on the invisible side of the CP. I cannot seem to trigger that happening now…

As for the question if this is good or bad - this is rather bad. The crosshairs shouldn’t be clipped and the object should be visible during creation when on the visible side. When on the invisible side? Tja… There probably shouldn’t be any visible feedback…

SysInfo:

Rhino 6 SR0 2017-8-24 (Rhino WIP, 6.0.17236.16061, Git hash:master @ 8d4635d257eb51a93a7590b8376cf648570e85b2)

Windows 7 SP1 (Physical RAM: 31Gb)

Quadro K3100M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.05)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-1-2017
Driver Version: 22.21.13.8205
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB


(Pascal Golay) #14

Hi Wim - Yep to the first bit, that looks like a bug, but I think it makes more sense to go ahead and show the feedback regardless of clipping and then clip the result as appropriate… I think you are saying no to that, correct?

-Pascal


(Wim Dekeyser) #15

I’m really just saying tja…
I don’t think there will by any real-world cases where I’ll be constructing something that is important on the wrong side of the clipping plane. It’ll be weird either way and so, yes, why not, show feedback regardless.


(Pascal Golay) #16

OK - I guess I am also thinking of the case where you’re making the thing in another view - I say it is more useful than wrong to show the feedback on the clipped viewport even if it is all in a clipped zone… Anyway, I’ll see about making feedback show regardless of clipping.

https://mcneel.myjetbrains.com/youtrack/issue/RH-40994
thanks,
-Pascal


(Steve Baer) #17

Not really; the only thing it means is that the standard call we make into a driver to report descriptive date and version isn’t really returning anything useful. It has no impact on the quality of the driver