Snap problem with selected blocks

blocks
snaps

#1

If objects are selected but hidden behind other objects, their edges are visible (yellow) and snaps work on them.
But with blocks, even though I see their yellow edges, snaps don’t work.


Bug when using the ClippingPlane. The preview, when creating objects, is not working
(Pascal Golay) #2

Hi Bogdan - I am not able, so far, to reproduce this - here’s what I see with a block instance(right) and non-blocks (left) selected and occluded by the plane:

Am I correct that you would not get this snap on the block instance but you’d get it on the non-blocks ?

-Pascal


#3

Try something like this:

If I want to move the block using one of the lower corners as Point to move from, I can’t, because snaps don’t work behind the polysurface.


(Pascal Golay) #4

Hm - that works fine here. If you set ‘Snap to occluded object’ in Options > ‘Modeling aids’ that should work but it also should not be different for block instances, it should be global.

Any luck?

-Pascal


#5

If i check Snap to occluded object it works. If i unckeck it works for everything that I select, except blocks


#6

And another request please:
I find it very useful to switch Snap to occluded objects On and Off all the time, but there is no command for it. It could be good to have the command SnapToOccludedObjects On Off so it can be assigned to a key like Orto or Gridsnap.


(Pascal Golay) #7

Hi Bogdan - this macro will toggle that:

! _NoEcho _-Options _ModelingAids _OSnaps _SnapToOccluded _EnterEnd

-Pascal


Object Snap not using foremost objects but gets lost in complex background objects
#8

Useful, thanks. The only inconvenient is that it breaks the current command, unlike Osnap On/Off