Bug: Video Refresh Issues with Later Rhino Releases

unhandled

#1

Hi,

I’ve been having 2 intermittent issues with redraw.

1.) Refreshes aren’t happening until I click on the window.

2.) Rotated Perspective window distorts image as I turn.

Is this a Rhino bug, or Nvidia?
Kind of unsettling.

Video Quadro K2100m, which worked fairly well with earlier releases.
Tripple buffering is off.
No forced AA or Anio.
“Use accellerated…” is on.
“Redraw scene…” is on.
“Do not use OpenGl…” is off.
Rhino is seeing/using Nvidia hardware.


(Wim Dekeyser) #2

Which version are you running?


(Nathan 'jesterKing' Letwory) #3

Pasting the output of _SystemInfo to this thread will help figuring that out.


#4

I am running the latest Rhino release. Windows 10, fully updated.

I take it by the underscore that, “_SystemInfo” was meant to be a Rhino command?
Yet: Unknown command: _SystemInfo

However, in nVidia, I can fetch this:
NVIDIA System Information report created on: 01/01/2018 01:10:08
System name: (Redacted)

[Display]
Operating System: Windows 10 Pro, 64-bit
DirectX version: 12.0
GPU processor: Quadro K2100M
Driver version: 385.41
Direct3D API version: 12
Direct3D feature level: 11_0
CUDA Cores: 576
Core clock: 666 MHz
Memory data rate: 3008 MHz
Memory interface: 128-bit
Memory bandwidth: 48.13 GB/s
Total available graphics memory: 14159 MB
Dedicated video memory: 2048 MB GDDR5
System video memory: 0 MB
Shared system memory: 12111 MB
Video BIOS version: 80.06.63.00.21
IRQ: Not used
Bus: PCI Express x16 Gen3
Device Id: 10DE 11FC 221E17AA
Part Number: 2044 0020

[Components]

nvui.dll 8.17.13.8541 NVIDIA User Experience Driver Component
nvxdplcy.dll 8.17.13.8541 NVIDIA User Experience Driver Component
nvxdbat.dll 8.17.13.8541 NVIDIA User Experience Driver Component
nvxdapix.dll 8.17.13.8541 NVIDIA User Experience Driver Component
NVCPL.DLL 8.17.13.8541 NVIDIA User Experience Driver Component
nvCplUIR.dll 8.1.970.0 NVIDIA Control Panel
nvCplUI.exe 8.1.970.0 NVIDIA Control Panel
nvWSSR.dll 6.14.13.8541 NVIDIA Workstation Server
nvWSS.dll 6.14.13.8541 NVIDIA Workstation Server
nvViTvSR.dll 6.14.13.8541 NVIDIA Video Server
nvViTvS.dll 6.14.13.8541 NVIDIA Video Server
NVSTVIEW.EXE 7.17.13.8541 NVIDIA 3D Vision Photo Viewer
NVSTTEST.EXE 7.17.13.8541 NVIDIA 3D Vision Test Application
NVSTRES.DLL 7.17.13.8541 NVIDIA 3D Vision Module
nvDispSR.dll 6.14.13.8541 NVIDIA Display Server
NVMCTRAY.DLL 8.17.13.8541 NVIDIA Media Center Library
nvDispS.dll 6.14.13.8541 NVIDIA Display Server
NVCUDA.DLL 6.14.13.8541 NVIDIA CUDA 9.0.163 driver
nvGameSR.dll 6.14.13.8541 NVIDIA 3D Settings Server
nvGameS.dll 6.14.13.8541 NVIDIA 3D Settings Server


(Nathan 'jesterKing' Letwory) #5

It was meant to be the Rhino command indeed. It is also accessible through the Help menu as the System Information... item

image

/Nathan


(Abraham Wechter) #6

and here…


#7

I am not using V6.
Menu item does not exist.


(Nathan 'jesterKing' Letwory) #8

Ok, you posted in Serengeti, which is for V6BETA/WIP issues, that is why we asked.

Do the draw issues persist with the current BETA?


#9

I am terribly sorry. I wish this thread could be moved to the regular forum.

[I haven’t tried the beta lately. I fear that improvements haven’t been made in the block manager.]


(Steve Baer) #10

No problem; just recategorized this post to be under Rhino for Windows.

We haven’t put out a service release for Rhino 5 for quite a while. Did you just update to SR14 or did you update something else like your version of Windows?


#11

Thanks, Steve Baer.

I’ve seen this bug for a while.

Version 5 SR14 64-bit
(5.14.522.8390, 5/22/2017)


#13

…and it’s still annoying.