Bug: Rhino needs Restart to update VAobjects in Twinmotion

Steps to replicate the issue:

  1. Create a scene with VAObjects and Direct Link it to Twinmotion (all VA objects transfer successfully)

  2. Change something in one or some the VA objects (Ie. Material or Style), hit Twinmotion Refresh icon in Rhino, or Twinmotion.

Refresh completes, but all VAObjects that were modified do not appear in Twinmotion (they vanish).

Have tried everything, updating VAObjects, deleting and relinking to Twinmotion, restarting Twinmotion, changing Twimotion link settings.

Only thing that works is to restart Rhino (leaving Twinmotion open, with file open).

Edit: In some VAobjects, randomly, there is no way to refresh then without deleting link and re-importing.

Afaik, updating regular Rhino objects does not appear to have issues.

Is anyone familiar with the issue or can replicate it? Any solutions other than restarting?


So nobody uses VisualARQ together with Twinmotion in this forum?

Hi @flatform
I use Rhino with Twinmotion but not with VA. However I also reported this bug with Rhino when not using VA. This should be reported to Twinmotion/epic developers too.

I see this in Rhino even without VA. I don’t know what triggers it? It seems history and undoing at some point loses the datasmith connection in Rhino even though it shows the connection as linked in Twinmotion. I too have to shut down Rhino and reopen Rhino and reopen the file. It would be great if McNeel could look into this. It might be hard to pin down since it goes away on reopening.

I Haven’t heard back from them on this problem it’s been about two to four months.


Interesting. Thanks for the reply. I only had issues with VAObjects and twinmotion refreshing, never Native Rhino Objects.

If it is a Rhino bug it is better to report it in Youtrack https://mcneel.myjetbrains.com/youtrack

It will be officially put in the bug list and you will be automatically inform of assignee, horizon, target version etc.

Hi @flatform,

In my opinion, this is a bug in the Twinmotion Expoter plugin for Rhino, developed by Epic.

Since VisualARQ 2.13, we have made some changes to fix all known issues related to real-time renderers. Those fixes seem to work well with Rhino’s Raytraced display mode, V-Ray, Enscape, etc.

I have met with the Twinmotion developers a couple of times in the last three years, and have already informed them of all the VisualARQ and Lands problems I knew about. Please report all those problems to Epic, so they are aware of them. They probably have to prioritize some bugs over others, so if they receive more bug reports from users, they can increase the priority of those bugs.



1 Like

This may be the case. indeed, issue on the Epic side.

Because we did not have problems with VAObjects in Lumion, before switching to Twinmotion. Have not tried Enscape, Some colleagues have it so we may experiment there with the same file.

Thank you for your insight.

1 Like

Hi @enric

Thanks for your response and for talking to the epic people.

This one is a hard one because it goes away after you shut down rhino and restart rhino. So it doesn’t make sense to send them a file. It looks like the connection is lost between Rhino and Twinmotion after some rhino edits or the link times out but I can’t figure out how to trigger it. Seems something to do with editing a model and undoing. I have alerted the folks at twin and at McNeel but unless you both run into it it’s going to be hard to solve without a method to reproduce it.

Have you personally encountered this? Do you have a file or info you can send to Twin to help pin this down? I’m going to file another report on Twinmotion but I don’t have good methods to reproduce this.

Thanks for your reply,

1 Like

I think twinmotion has in general some issues with IDs. Per example, even if the specific objects are not refreshed, it is very often (more than not) for custom Rotators to stop functioning for no reason. Ie. You add a rotator and link it to an object, then it stop
working. Even if you break the link to the object and you relinking, it does not work, unless you delete the Rotator and start frok scratch.

Not sure if it is related to Datasmith Sync (if it happens only after that) but still a great issue for those that need to add interaction.

Twinmotion is a great piece of software but needs some anti-bug love.

I agree, Twinmotion is indeed a great piece of software and its render engine (Unreal) is one of the best real-time engines.

But unfortunately, I think that the Twinmotion Export Plugin for Rhino is not at the same level. I understand that they have to create several connection plugins for various platforms, and each platform will have its own particularities.

1 Like

I’ve heard a couple colleagues say in the last couple weeks that they’re interested in moving to Twinmotion, simply because the UE rendering engine is much more flexible than Enscape. In other words, I think we’re all getting sick of the same flavor of render coming out of the Enscape engine.

If anyone else is working with it, make sure the twinmotion developers hear about the VA/Rhino users.


Hi @flatform
“Not sure if it is related to Datasmith Sync (if it happens only after that) but still a great issue for those that need to add interaction.”

Yea I run into this when you update a door from Rhino to Twin with a rotator connected. That looks like a Twin motion bug. The other one I mention is still a problem don’t know if it’s Rhino timing out or Twin.


1 Like