Bug: Properties Panel Not Updated

This is a bug I have seen since V8 came out but I am finally annoyed enough to write.

That is, the Properties panel stops updating for an extended period of time. Usually, when this happens it displays the viewport properties. Here I have a text box selected but the properties panel does not show the text box…

I sat and waited three minutes and the panel updates on its own.

It looks like there is something going on in the background that blocks the properties panel from updating.

I have also seen this where selecting object-1, then select object-2, and object-1’s properties sit on the screen for a minute or so. However, this is much rarer than seeing the display properties being displayed.

A little more information, in this scenario:

Click Object-1.
Click Object-2 => Property panel does not update immediately.

Wait for a while

Properts panel updates
Object-2 is unselects on the screen.

Making changes to the Properties panel updates Object-2 even though it does not appear to be selected.

Interesting, can you run SystemInfo in Rhino and post the result as well as the file? I’ll try to repeat.

If it proprietary you can send it privately here…

Thanks

It doesn’t happen all the time. It’s intermittent.

Rhino 8 SR9 2024-6-19 (Rhino 8, 8.9.24171.03002, Git hash:master @ c7bc7dce8c2b456b3f0c5f0fa669295aa802ef1a)
License type: Commercial, build 2024-06-19
License details: Cloud Zoo

Apple macOS Version 14.5 (Build 23F79) (Physical RAM: 64GB)
Mac Model Identifier: MacBookPro18,2
Language: en-US (MacOS default)
.NET 7.0.0

Metal GPU Family Apple 7
Metal GPU Family Common 3
Metal GPU Family Mac 2
Graphics processors
Apple M1 Max
Color LCD (1728 x 1117 @ 120.00Hz)
GPU Vendor: Apple

USB devices
None

Bluetooth devices
None

Third party kernel extensions
None

Third party plugins
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftCoreImage.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftMetal.dylib
/usr/lib/swift/libswiftOSLog.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftQuartzCore.dylib
/usr/lib/swift/libswiftUniformTypeIdentifiers.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswift_Concurrency.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/swift/libswiftsimd.dylib
/usr/lib/swift/libswift_StringProcessing.dylib
/usr/lib/swift/libswift_RegexParser.dylib
/usr/lib/swift/libswiftCryptoTokenKit.dylib
/usr/lib/usd/libusd_ms.dylib
/usr/lib/swift/libswiftCoreAudio.dylib
/usr/lib/swift/libswiftCoreLocation.dylib
/usr/lib/swift/libswiftCoreMedia.dylib
/usr/lib/swift/libswiftCompression.dylib
/usr/lib/swift/libswiftCoreMIDI.dylib
/usr/lib/swift/libswiftAVFoundation.dylib
/usr/lib/swift/libswiftCoreML.dylib
/usr/lib/swift/libswiftFileProvider.dylib
/usr/lib/swift/libswiftIntents.dylib
/usr/lib/swift/libswiftAccelerate.dylib
/usr/lib/swift/libswiftGLKit.dylib
/usr/lib/swift/libswiftGameplayKit.dylib
/usr/lib/swift/libswiftMetalKit.dylib
/usr/lib/swift/libswiftModelIO.dylib
/usr/lib/swift/libswiftSceneKit.dylib
/usr/lib/swift/libswiftSpriteKit.dylib
/usr/lib/swift/libswiftVision.dylib
/usr/lib/swift/libswiftRegexBuilder.dylib
/usr/lib/swift/libswiftDemangle.dylib
/usr/lib/swift/libswiftShazamKit.dylib
/usr/lib/swift/libswiftObservation.dylib
/usr/lib/swift/libswiftVideoToolbox.dylib
/usr/lib/swift/libswiftWebKit.dylib
/usr/lib/swift/libswiftNaturalLanguage.dylib
/usr/lib/swift/libswiftSystem.dylib
/usr/lib/swift/libswiftMapKit.dylib
/usr/lib/log/liblog_network.dylib

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 8.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 8.9.24171.1002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 8.9.24171.3002
/Applications/Rhino 8.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 8.9.24171.1002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCodePlugin.rhp “RhinoCodePlugin” 8.9.24171.3002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 8.9.24171.3002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 8.9.24171.3002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PDF.rhp “PDF Export” 8.9.24171.3002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 8.9.24171.3002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 8.9.24171.3002
/Applications/Rhino 8.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 8.9.24171.1002
/Applications/Rhino 8.app/Contents/PlugIns/SectionTools.rhp “SectionTools” 8.9.24171.1002
/Applications/Rhino 8.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 8.9.24171.1002
/Applications/Rhino 8.app/Contents/PlugIns/Displacement.rhp “Displacement” 8.9.24171.1002
/Applications/Rhino 8.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 8.9.24171.1002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 8.9.24171.3002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 8.9.24171.3002

Thanks, even if i can’t get it reproduced for a bug report, posting the info is helpful and will be reviewed.

Here’s another example. I’ve selected a text box.

Then I select another text box, but the properties for the first text box are displaced. If I change the text, the first text box gets updated.

I select a dimension and the same thing happens

This took 3 minutes for Rhino to update the properties.

Am I the only one seeing this?

I am getting it constantlly now particularly in layouts.

I frequently have to switch to a view then back to the layout to get Rhino unjambed here.

Hi John -

Please upload a file so that we have something to work with.
-wim

I updated one (of many) where it occurs frequently. I do a lot of text editing, layer changing, and style changing in a layout. Then Rhino either has a long delay between selection and updating or does not update at all.

When the latter happens, I have to switch to a view then back to the layout to reset.

Hi @miano,
We tested your model here and experienced no issues with the Property panel.
We were testing with Rhino 8 sr10 WIP that will be out Wednesday as the release candidate.
See the performance we have getting with your file in this video.

We can see you took your screen captures from the Top model viewport, so that is where we tested.

Since is happening sometimes and then not others, and since it is obviously not following the file, we will need you to keep any eye on it.
And you can test with the SR10 Release candidate next week when it is released.

Let us know if you come up with any details on how to duplicate the behavior on our computers. If we can duplicate the issue on our computers. then we can write a bug.

Thanks for your help.
Sincerely,
Mary Ann Fugier

I see it more commonly in the the layouts. 1:192 is the one I used more recently.

I have not yet found a sequence that causes the problem. I just seems to happen after a period of time,

Hi @miano,
I worked with this some more today in your file and on a layout set to 1:192.
But never reached the point where the issue occurred.
See video here.
Throughout the session the speed of editing with the panel remained snappy and as expected.

These are very difficult issues have.
Keep your eye on the trigger.
If you come up with something repeatable, let us know so we can try it here.

Sincerely,
Mary Ann Fugier

The Mac Gods must hate me.