Bug - Mess with the Text Styles - Latest WIP


#1

Hi guys,
I am facing problems with text objects in latest WIP.

I added a new style with Font setting, height and alignment.
After reopening file again Style is saved, however font - is not.
Moreover - empty lines appear in the text objects!!!

Can you please look at this?

Kind regards,
Dmitriy


(Pascal Golay) #2

Hi Dmitry - so far in my quick test this appears to work as expected. I see the text alignment controls are a little squirrely at the moment but my annotation style seems to save in the file OK and survive a close/reopen. Can you try the simplest possible test - new file, add an annotation style, change font, height and alignment, then make some text using this, save, close, reopen… is that what you’ve done so far?

-Pascal


#3

Hi @pascal

Please find file enclosed.Bug_TextStyles.3dm (36.7 KB)

When I try to change Font of the text - I can do it.
But after I open saved file, Font is set back to Arial.

Thanks,
Dmitriy


#4

Hi @pascal
have you tried my file to see if you can repeat behaviour?

Thanks,
Dmitriy


(Pascal Golay) #5

Hi Dmitry - we have a bug logged here -

https://mcneel.myjetbrains.com/youtrack/issue/RH-39018

I think that is the same thing.

Thanks,

-Pascal


#6

Thanks @pascal

in addition to the Font problem, new empty lines are added to the text after I reopen the file. Thus alignment is not correct anymore.
I really hope that text-related problems could be solved in the upcoming WIPs.

Thanks,
Dmitriy


(Lowell Walmsley) #7

@Dmitriy - What fonts are supposed to be used by the styles in that file?
Is the text supposed to have a specific font used, or is it supposed to use the font from the style?


#8

Hi @lowell

Thanks for contribution here.
I am looking for simple behavior for now - so font from the style. So, if I select a text which has Default style, and change it to custom style - I expect font, height and alignment to change according to the custom style.

Moreover, I have noticed that after I reopen file, majority of the text objects are losing its font assigned by Style, but some of them keep it. very strange…

Thanks,
Dmitriy


(Lowell Walmsley) #9

Does that mean

  1. that you have defined a custom style and you change the text to use that style?
    or
  2. that you used the controls in the ObjectProperties page to change the specific text you selected?

Either way, the changes should stick, but I’m trying to figure out what to trouble shoot to figure out what’s happening.

I asked you what fonts were supposed to be used by the styles, but I’ve figured that out now. I don’t have that font and the controls work differently for me because of that, which I also need to fix.


#10

Hi @lowell

I used controls in the ObjectProperties page.
The font I have been using is called Agency FB.

Thanks,
Dmitriy


(Lowell Walmsley) #11

Thanks. I don’t think there’s anything special about that font except that I don’t have it.

Changing the text using the controls on ObjectProperties doesn’t change the style. It makes overrides to the style for that specific text. That means that the changes won’t change any other objects or the defined styles.

In a current build here, which will be in the WIP next week, override properties appear to save and read properly.
I’ll check with you again next week.
I don’t have the specific build that went out as a WIP handy, but it may also work


#12

Hi @lowell

Just some feedback from the latest WIP.
Seems that Font is saved now, however, the issue with added empty lines as reported back by me is still present. This would not disturb me but it changes position of the text.

Thanks,
Dmitriy


(Lowell Walmsley) #13

How can I duplicate what you’re talking about with the new empty lines?


#14

Hi @lowell

was trying to reproduce it but seems everything works fine now.
I will check also the very latest WIP and revert if smth goes wrong…

Thx.


(Lowell Walmsley) #15

Sounds good. Thanks for the update.