Bug in SetObjectDisplayMode Mode=UseView

There seems to be an issue with SetObjectDisplayMode where Mode=UseView wrongly points to shaded. But if I click on Mode and then click on option UseView it works.

I see this if I make a mesh and then make a SubD mesh from that mesh.

I’ll provide a file if needed.

Hi Jorgen - I’ll check it, thanks.

So far this works here in my simple test - if you have a file that shows it, that would be helpful - thanks.