BUG in latest Rhino 7 (flashing selected surfaces)

Hi, recently I updated to the latest Rhino 7 service release (7.6.21124.9001, 2021-05-04) and I noticed that there is a visual bug when creating a scene from scratch. The bug does no appear while working on already made scenes with plenty of objects, though. It only occurs if there are a few newly created surfaces and one of them is being selected. Very strange. Also happens on rebuilt surfaces with any degree and control point count.
It’s not a problem with the graphics driver, because I used it with no issues with the previous Rhino 7 update on newly created scenes. The bug came into existence after the latest update. Just in case I also upgraded my graphics driver now, but the bug still persists.

I can reproduce this here. Looks like this happens only on horizontal flat surfaces and only on the ones that are the lowest in the scene, so I suspected it might be a conflict with the ground plane. Looks like you have modified most of your display modes, and you probably have it turned on in them, with “Automatic altitude” checked. When there is a flat surface lying directly on the ground plane, you get this effect - like when you have two coincident planar surfaces. If there is only one horizontal surface in the scene, the “automatic” setting will move the ground plane up/down to that surface’s level.

FWIW, I can make this happen in V6 as well, so I’m not sure it’s a new “bug”.

It also happens on raised surfaces that are higher that other surfaces along the Z-axis, even on default view models that are not altered by me. I tried this as well.
Also, the problem occurs with surfaces that I rebuilt into degree 3 and point count above 4 in either direction whose inner points I raised relative to the border. If I keep their border horizontal, the graphics bug is clearly seen there once the surface gets selected. Looks like it’s really related to the Z-axis height on the lowest surface in the scene.

I don’t see any of that here - can you post a file with an example or two?

I’m not seeing any of this here so far…


Yes, here is a sample file in Rhino 7 file format:

Funny bug.3dm (30.4 KB)

Pascal, this never happened to me in prior years. I usually tend to build my free-form models from planes exactly like that one, so it’s an even bigger surprise to me that this occurs just now.

I don’t use ground plane. Also, the graphics bug only occurs when the surface is selected. :slight_smile:

Are you sure you didn’t change this in your custom display mode? I can repro this only with groundplane set on. Or partly when I change grid settings to some combination with transparent.

When I have in a custom display mode based on shaded the ground plane turned on (and set to shadows only), then I get the problem when selecting the lowest surface.

I was also thinking on that.

I am not able to reproduce that visual flickering here, very strange issue…
Rhino for Mac Version 7 (7.6.21117.09002, 2021-04-27)

Rodolfo Santos

I just figured out that for some reason after the update my Rhino 7 uses the default template “Large objects - millimeters” instead of my custom version that was loaded prior the update from another folder and worked fine until recently. Very strange. My custom template has the ground plane turned off, while the default “Large objects - millimeters” of the updated Rhino 7 has the shadows of the ground plane turned on. I figured out that by looking at the grid that seemed too different to me in the recent days. Now I understand why. :sweat_smile: Because after the update it was no longer my custom grid (shown on my last screen-shot below).

Solved then.

Rodolfo Santos

Yes, it’s solved for now. Unless the next update brings the bug again. :smiley: I had to replace the default template “Large objects - millimeters” with my custom version. Not sure why the latest update ignored my custom template and reverted to the default one. Previous updates were working nicely.