BUG: Force Vertical or Horizontal DIM is broken

Both the Vertical and the Horizontal DIM commands are broken. They both acts like ordinary _DIM commands where the “pause pause Horizontal/Vertical” option in the macros are ignored since there are no such options in the command any more.

Please fix :slight_smile:

Yes, these are very useful options.
I can confirm this.
I wonder if any of the command options work any more.
My Rhino Version: Rhino 6, 6.13.19058.371
Rhino 5 is confirmed to still work.
Has this been addressed?

Hello - as far as I can see here, this works as expected - if you run ToolbarReset and restart Rhino, do you still see the problem?


I filed an issue a little while ago - I’ll find it.
The issue only happens under specific circumstances…

Here we go: RH-51445

Ah, OK- I guess that is a slightly different thing - the OP here was about the macros in the specific horizontal and vertical buttons, which (I think) are currently at least, correct.


1 Like

Yes, the problem still exists.

If I use the horizontal dimension button (In the Dimension Tab) it should always create a horizontal dimension no matter how I select the points.

If I select points that are more vertical than horizontal I get a vertical dimension when I expect a horizontal dimension.

The same issue exists with the vertical dimension button.

Hello - I think the bug you see is what @wim reported. - can you confirm that if you place the dims in the Front view it works as expected from the buttons?


Yes it does seem to work okay in the front view.

Most of the work I am doing now involves working with 2d shapes and I use the top view for these jobs.

I didn’t think of trying a different view.

Thanks, Jamie.

I also ran across this bug today. Very surprising in such mature software. Did it break recently from some related update?


Btw, I am able to create a vertical dimension when the gap is very large. I only see this when I want a vertical dimension from an almost horizontal line.

EDIT: I can confirm it is broken the other way around as well. I tried to create a horisontal dimension from two points with mostly vertical separation, and Rhino forced a vertical dimension on me instead.

Not recently, no.

Are there plans on ever fixing this issue? This seems to have been broken since version 6 was released.
It makes my work much more difficult than necessary.

@jamiechi From YT i see it is planned for v7 …

However i tried it and i probably dont understand the issue ?

Ahh i understand they should be fixed while all behaves the same.

Yes, it does appear to be fixed in V7 WIP