Bug: Display Settings Are Not Being Saved

The display settings show a change, but when you exit the options dialog it reverts back.

There is another issue with toolbars not being saved on exit. It looks like changes to toolbars are only saved when you save the file as V6 and exit. Toolbars are not saved when you save as V5 and exit. Rhino knows not everything was saved in the V5 format and prompts you to save again, but if you decline it won’t save the toolbars.

Hi Eric- thanks, I’ll check this.
I see edge color reduction is not being saved… Hm! actually it looks like it is being set by the top level edge reduction color.

But so far the rui file seems to be changed correctly - do you have more than one Rhino open?


Options reverting back when exiting the dialog is IMO fixed in 6.2, or otherwise at least the release candidate for 6.3. The revert happened do to decimal separator setting in Windows, possibly comma in your case.

What version are you on? If it is 6.0 or 6.1 please consider updating.

Hi Nathan - I think this is different - that one setting (surface naked edge color reduction) does nothing on its own, the number is set by the top level edge color reduction number. I’ll make a YT item if I cannot dig one up for this, I think it might already be on the pile.


Aye, that is different, but the user also says changes revert after exiting the dialog… am I missing something?

Could be two bugs! Yeah, if other settings reset then it’s the thing you mentioned no doubt.


Yes, I have Rhino 5 open. It reverts back as soon as the dialog closes. I’m running latest build (6.3.18064.23201, 3/5/2018).

Can you tell what the decimal separator is set to on your machine? Under region and language settings check the number format, I think. If it is something else than the dot, could you try setting it to the dot, restart rhino 5 and test if settings stick after closing the dialog? I don’t think you need to restart your machine.

Standard USA setup:

Hmm, not sure then what goes on with settings resetting on dialog exit.