Boundary surface glitch

Hi this is possibly a silly question but I’m getting an odd error in boundary surface:

  • I’ve got two polyline curves that overlap each other
  • I offset them both (first picture)
  • I plug both components into a boundary surface

When I run both together, the second boundary surface doesn’t see the holes, but the first one does? When I run them individually (list item = 0, 1) the boundary surface does see the holes. Is there something with the data structure that I’m missing/doing wrong?

Hello, I’m using Boundary Surface as well, and I’m getting some “random” anomalies. Trying to sift through to see what might cause this, but I can’t figure it out either.

Screen Shot 2020-11-24 at 11.38.53 AM
This shot shows one anomalous list item.

Screen Shot 2020-11-24 at 11.39.09 AM
This is how most items look

Screen Shot 2020-11-24 at 11.39.43 AM
And here is the result.

This very well could be a different issue that original poster, but this seemed like the most related issue I could find. Any advice? My file is in process, but it’s attached. Kessler Surface 2 (53.2 KB)

Also, there is the other anomaly type that is more similar to the original post. Seen in larger configuration:

Yeah it looks like a very similar issue, I wonder whether there’s a programming glitch that we just can’t figure out?

It seems like it might be a component glitch.

I simplified it and tried making sure the tree structure was exactly what I wanted, and it’s still not doing what it should.

Works right here.

But if I just move the curve over a little bit, I get the same failure you got.

If you mess around with this I think you’ll find that the error is dependent on some number of overlaps or some number of one set’s vertices being within the other’s boundaries. I can’t quite figure it out.

Here is a very silly workaround that solves the problem, again, with excessive merge and list item components that are just there to keep me sure I didn’t fumble the order I connected the wires in:

1 Like