Blocks and transparency in RENDER view mode

Any way to make blocks not seem transparent? I’ve been having to explode the blocks and bring them out of block mode to show clients, which defeats the purpose of blocks.

Hello - I’m not sure I follow - do all of your blocks show transparent?


Yes. Here’s a shot of a block (on the right) and that same block copied and exploded next to it (left). I would like the block to look “normal” like the version on the left.

Hello - is the block mirrored?


No. The exploded version was mirrored. Mirroring has no effect on this ghosting look.

Can you please save a small file that has a block showing the problem and posat it here or send to



Attactest.3dm (462.3 KB)

If the file has one barrel then AFAICT it shows up as expected without exploding.

I only changed the bg to gradient to show up better, and made a copy:

If this is what it should look like then please attach the output of the Rhino command _SystemInfo

No, mine still has no definition in rendered mode.

Then please attach the output of the Rhino command _SystemInfo.

Here it is:

Rhino 6 SR9 2018-8-28 (Rhino 6, 6.9.18240.23591, Git hash:master @ b4cafe26bc47962f97a851a4a1546836d2612200)
Licence type: Evaluation, build 2018-08-28
License details: Stand-Alone
Expires on: 2018-09-24

Windows 10.0 SR0.0 or greater (Physical RAM: 24Gb)
Machine name: PETERS-PC

GeForce GTX 965M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 398.36)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-24-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.9.18240.23591
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.9.18240.23591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.9.18240.23591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.9.18240.23591
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Does it still happen after you disable the V-Ray plug-in? To disable go to Tools > Options > Plug-ins, scroll to the V-Ray entry, right click and select the entry Enable Load Protection. Then restart Rhino and see if rendered mode now shows blocks better.

Did as you suggested and still looks the same.

@pascal, any further ideas?

No… I’ve been poking at this but it all looks OK here. @PeterB - does this block also look wrong?

testTransparentBlockMaybe.3dm (464.2 KB)


This is what I get in rendered mode, so it’s still the same problem…

Hi Peter - is your render mode set defaults?


1 Like

I reset to default for rendered view and that seems to have solved the problem. I must have changed something in rendered view at one point that caused this issue. Thanks for the question/solution!