Block import SR22 Bug?

I and my colleagues have a workflow where we import part files into a larger master model as linked blocks. This have a good advantage because the information in the drawing tabs in the part file is not imported into the master file. But recently (since SR22?) everything, all drawings in the part file tabs is imported into the model tab and the master file becomes extremely messy.
I hope and suppose this is a bug and will be fixed?
I attach a picture of a import test.

Hi Fredrik - I am not getting this result here so far… are the files just plain Rhino files that have layouts? And Import not Insert…? (neither brings layouts here)


This happens when I insert a Rhino file. Try to make a new layout and put some lines, drawing window and dimension in the layout space and save. Import this file into a new rhino file as a block. I get all that objects appearing in the model space. Here is a real example; everything inside the red line comes from imported layout space.

Hi Fredrik - my tests do not show what you describe so far - if I do not have anything in model space, Rhino refuses to create a block from the file, regardless of any geometry in layout; if I have geometry in model space, only that comes along. Are you running any non-defaut plug-ins?


Yes I run some scripts and plugin but no new recently installed. Is there a way to make a screen dump or text file of all non default plugins?

Hi Fredrik - please run the SystemInfo command and copy/paste the results here.


Rhino 6 SR22 2020-1-28 (Rhino 6, 6.22.20028.13281, Git hash:master @ 379871ece695dc096e83826f08b429db8ca2e7f5)
License type: Commercial, build 2020-01-28
License details: Cloud Zoo. In use by: scenografi ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-042MSUJ

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 (NVidia) Memory: 8GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 432.00

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\BoltGen1_63.rhp “BoltGen”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Fredrik - I guess this has been fixed - I was not aware of this bug, or forgot it…


Thanks Pascal
I didnt find that post when searched.
So where do I get the fix? Do I have to wait until SR23 or do I rollback to 21?
Thanks Again /Fredrik

Hi Fredrik - I guess you are in the best position to answer that question.
Next week’s SR 23 Release Candidate 3 will most likely include the fix (on Mac, the fix is already available in the latest public build). It will be a few more weeks before the final SR 23 will be out, though. So, if you rely on final SR’s, you will probably want to roll back to SR 21. You can find a link to that from this post:


Hi Wim
Thanks for reply!
/Fredrik (SVT)

Takk for sist, Fredrik!

1 Like