Blast from the past

Hello All,

I am still on Rhino 3, as it works great and we only make very simple drawings. However, someone sent me a couple of simple 2d dxf files that had been drawn in solidworks and saved as dxf’s. These have opened fine and i can see all the correct data.

The big problem i have now is that when i come to export a drawing, the only option i have for file type is .3dm there is no option for dxf, AI etc etc they have all disappeared! I have closed Rhino, reopened it and even just drawn a rectangle on a fresh page and tried to export or save it and its only giving me the .3dm option.

Can anyone shed some light on it?

Thanks in advance

What do you see in your C:\Program Files (x86)\Rhinoceros 3\Plug-ins directory?
(I’m not sure the path is correct, haven’t seen a V3 installation in more than 10 years…)
Are there ACAD import/export plug-ins in there?

If so, when you go to Options>Plugins, is/are the plugins checked as loaded? If not, try checking them and restarting Rhino.

Thanks for the quick reply.

this is what i have, they seem to be installed??

This is the only file option i have when exporting.


what about downloading a 90days trail version of Rhino 7 and do the export there ?

Nope, the ACAD import/export doesn’t seem to be installed. AFAIK, you should have a plug-in called

and one called

in your plug-ins directory, and they should show up in Options>Plugins.

(the above is Rhino 5, the oldest I have installed)

You might try a re-install of the program…

Ah ok, that’s not good. Its seems these solid works files have killed it some how!

I still have the original book and CD, so will do a fresh install. I did a fresh install at earlier this year when i put an SSD in this PC.

We originally got Rhino when we bought a CNC router from Pacer back in 2006 and its works a treat. I am probably just being tight by not upgrading but we only cut very simple panels on this router, so i am loathed to upgrade.

Thanks very much for the quick replies.

the trail version is free and fully functional for 90 days.
you can even save old rhino 3 file format.

This would help me for these files but won’t fix my Rhino 3 going forward!


Hi Chris - If you look in the Rhino installation folder for th plug-ins folder, locate the Acad ones, or all the rhp files in that folder and drag and drop them onto an open Rhino window; when it’s all done, close and reopen Rhino - any better?
Also, are you running V3 in compatibility mode on Windows 7-8-10-11? If not I’d try that.

Thanks Pascal,

This has worked, i opened the plugin manager and installed the Auto Cad DWG/DXF and the AI export files and this has worked. These are the only 2 i use, so i just did these ones.

Thanks for all the help guys, this should keep me going for a while longer. I will eventually get round to getting and upgrade!


:thinking: What’s the Bonus in the menu bar for?

Bonus tools! I think they had a separate menu in V3.

:crazy_face: Good old days when you get major feature updates without a major version re-purchase.

These days, they’re called “plug-ins”… :smile:

1 Like