Bad update: Rhino 7 SRC19 REMOVES support for legaxy 3Dconnexion devices

I just upgraded from Rhino 7 SRC18 (rhino_en-us_7.18.22116.07001.exe) to SRC19 (rhino_en-us_7.19.22130.15001.exe) and immediately noticed that the latest version introduced a critical downgrade regarding the plug-in for 3Dconnexion devices! The latter no longer works with my SpacePilot that up to version SRC18 was performing perfectly fine via replacing the default 3dxrhino.rhp file with one taken from Rhino 6.5 (which in reality was a Rhino 5 plug-in still used in early Rhino 6 releases) in the C:\Program Files\Rhino 7\System folder. That’s quite sad, because it means that I have to downgrade back to Rhino 7 SRC18 and stick with all the bugs that were present up until today.
Modern 3Dconnexion devices that I tested in the past few years performed noticeably worse in comparison with the SpacePilot, especially for fine movements with higher speed and increased dead zone.
Is there any chance to fix this huge inconvenience and add support for the previous 3dxrhino.rhp plug-in for Rhino 7 SRC20 that was successfully used up until Rhino 7 SRC18?


P.S. This is the old plug-in from Rhino 5 that shipped with Rhino 6.3 that worked very well with Rhino 7 SRC18. It worked together with 3DxWare 10.3.0. Sadly, SRC19 no longer accepts it, because it raised the requirement to 3DxWare 10.5.6 for no obvious reason…
3dxrhino.rar (130.6 KB)

Hi @Rhino_Bulgaria,

From what I can tell, the 3dxRhino plug-in has not changed since March of 2021. The message you are seeing has been presented by the plug-in for a few years (too).

I guess we will need more information on what you’ve got going on - what version of 3dxRhino are you or have you been using.


– Dale

My twelve year old corded Space Mouse works with Rhino 7 SR19 2022-5-10 (Rhino 7, 7.19.22130.15001 using the 3DConnexion plug-in which ships with Rhino 7.

Rhino 7 SR19 2022-5-10 (Rhino 7, 7.19.22130.15001, Git hash:master @ d1ce997263f5027a4d6f62f5f4e193055e56beff)
License type: Commercial, build 2022-05-10
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 4-20-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.59
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-20-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\dcock\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”
C:\Users\dcock\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.21.831\SectionTools.rhp “SectionTools”

Hi Dale, I repaired Rhino 3 times and also reinstalled it twice. Also, reinstalled the 3DxWare 10.3.0 driver twice. Something prevented the plug-in and driver to work together, but finally, after all of those re-installs, my SpacePilot works again. I didn’t had those troubles with inability to use it after updating to newer versions since I got Rhino 7 when it first came on the marker back in December 2020.

It would be really nice if “McNeel” considers adding an option in the Rhino settings to use an alternative legacy plug-in (like the one I uploaded above taken from Rhino 6.3, which is actually from Rhino 5) as a way to support discontinued 3Dconnexion devices. Or, at least add support in the Rhino settings to control the sliders to adjust the speed of each of the 6 axis of the 3d mouse’s handle, as well as ability to customize the buttons and create macros. Those are absent from the Properties panel for the 3d mouse in Rhino.

My SpacePilot was officially axed by “3Dconnexion” back in 2013, when they stopped supporting it by intentionally removing it from the list of supported devices in their newer drivers (a.k.a. “planned obsolescence”). While the 6-directional cap of my SpacePilot works without any driver with Rhino 7, this way it lacks any ability to set different speed for the individual axis, nor any settings to the custom buttons (18 in total). Also, inability to create macros and use the LCD screen. Those are only available via installing the 3DxWare 10.3.0 driver, which is the best one for use with SpacePilot.

I had another issue like that after installing the latest Rhino 7 version. There was a warning message saying the following:

"An unhandled exception occurred in your 3DxWare driver session, would you like to save a diagnostic file?"

The problem was caused by leftover files located in the C:\Users*username*\AppData folder. There are 3 folders in this directory: “LocalLow”, “Local” and “Roaming”. The last two of those folders include sub-folders called “3d connexion” and “3d mouse”.

The solution is as follows:

  1. Unplug the 3d mouse from the USB port of the PC;
  2. Uninstall the 3d connexion driver (3Dx Ware);
  3. Open C:\Users\Bobi\AppData\Roaming and C:\Users\Bobi\AppData\Local and manually remove any leftover folders there called “3d mouse” and “3d connexion” that consist various settings from the deleted driver (they remain even after its uninstallation and cause an unwanted conflict with the new driver);
  4. Restart Windows;
  5. Check again those folders for leftovers. Delete them if there any;
  6. Install the 3d connexion driver (3Dx Ware);
  7. Connect the 3d mouse to the USB of the PC. Important: some legacy devices don’t work fine with USB 3 ports, so use USB 2 instead.
  8. Run Rhino. Now everything should work as expected.