3d connexion plugin for Rhino 5


I just installed the driver for the “spacemouse” 10.6.8 on windows 10 64bit. In my rhino 6 installation everything works as expected but it doesn’t install a rhino plugin for V5 (64bit). Is this unsupported now or maybe someone has the “3dxrhino.rhp” for V5?


I found this version of the plugin somewhere on the internet; It works but there is no support for the different navigation modes. Has someone the current version for Rhino 5 64bit?

3dxrhino.rhp (394.7 KB)


EDIT: with the command “! _SpaceMouse _Popup_Menu” there are some of the options but now the movement is quite choppy. I still suspect my .rhp is not the right one.


@Markus (Markus Bonk) is the driver guy from 3dconnexions that would be the best source for information on V5 and V6 Spacemouse drivers

The correct 3DMouse plug-in for Rhino is part of the Rhino distribution. 3DxWare has never installed a plug-in for Rhino.

Possibly stopping the 3Dxware driver, deleting / renaming %appdata%\3Dconnexion\3DxWare\Cfg to clean up any incompatibilities with older user profiles helps.

Sometimes a new install of 3DxWare requires a reboot.

thanks @John_Brock & @Markus,

apparently I deleted the file sometime in the past. @Markus Could you post the current version of the plugin here? I would appreciate it :grinning: And I will try to reinstall the driver as you suggested

Sorry, I don’t have Rhino 5, nor the plug-in. @John_Brock should be able to help you to repair your Rhino 5/6 installation.

Hi Konrad -

I’m not sure which file you are referring to here…
At any rate, to repair your Rhino 5 installation, go to the Windows Control Panel > Programs > Programs and Features, find Rhino 5 (64-bit) in the list, right-click and pick Repair from the options.

1 Like

Does that mean that if “McNeel” decides to allow support for an alternative “legacy” plug-in (like the one used in Rhino 5 and up to Rhino 6.4) for future Rhino 6 and Rhino 7 releases, it will be possible for the latter to support use of older “3d connexion” devices such like SpacePilot (its 3d cap basically outperforms the ones found in the modern devices), whose support was excluded from the newer 3Dxware drivers? :slight_smile:

No @Rhino_Bulgaria. The plug-ins are compiled at the time the rest of the application is built. The last time we wrote a 3dconnexion plug-in was V4. Since then 3dconnexion builds the driver and we include it in the distribution.

It was about couple of years ago when my SpacePilot worked wonderfully with early Rhino 6 service releases and the program was recognized by the 3Dxware driver as Rhinoceros 5 (SpacePilot has an LCD screen that shows such information). However, later releases of Rhino 6 removed support for the plug-in used so far, and instead shipped with a different plug-in that no longer allowed SpacePilot to be used with Rhino 6 (and Rhino 7 WIP, as some users noticed).

Yesterday I tried again to replace the plug-in in the latest Rhino 6 evaluation (check the version below) with an older one that someone took from Rhino 6.2 and uploaded it on the Web, but a warning pop-up window appeared that mentioned that the version of the plug-in was compiled for a different version of Rhino. The default plug-in that ships with the recent Rhino 6 releases no longer supports the older 3DxWare driver 10.3.0 (3DxWinCore version: that’s the best performing driver for use with SpacePilot (firmware v. 4.05). As far as I remember, Rhino 6.4 was the latest one that worked with SpacePilot and was recognized as Rhino 5. That suggests that the plug-in in newer Rhino 6 releases was definitely changed with a new one that discontinued support for 3DxWare driver 10.3.0 (and SpacePilot, as a consequence).

Rhino 6 SR25 2020-4-23 (Rhino 6, 6.25.20114.05271, Git hash:master @ f35d7ded15ec317635ced435d8df84327397038d)
License type: Evaluation, build 2020-04-23
License details: Stand-Alone
Expires on: 2020-05-28

thanks, repairing did the trick :hugs:

sorry to bother again, but I am still at odds with the driver/plugin form 3d connexion. when I use the spacemouse the framerate drops to around 40 (from locked 60). It’s pretty bad and stutters heavily. I look in the 3d connexion forum and it seems there having quite some problems with their software. :face_with_raised_eyebrow: I tried the following but without luck so far:

  • updating gpu drivers
  • calibrating the device
  • turning logging off/on
  • all versions of the 3d connexion driver
  • unplugging all usb devices other than spacemouse
  • uninstalling logitech drivers

did someone encounter this frameratedrop alswell?

thanks again


normal mouse: