Bad STEP import V6 correct V5!


#1

When I import the attached step file from Fusion the through holes have an extra cylinder inside.

V6
image
V5
image
CoreWireBlock.step (185.5 KB)

Thanks Mark


(Pascal Golay) #2

Hi Mark - I see this, thanks.
It looks like the holes have incorrect trims - if you untrim the cylinder it takes the right diameter. I’ll get this on the pile, thanks.

CoreWireBlock.3dm (397.9 KB)

https://mcneel.myjetbrains.com/youtrack/issue/RH-44286

-Pascal


(Simon Heufers) #3

Hello!

If I open step files —one or another solid is missing. (Rhino 6)
No problems with the same objects in Rhino 5.
Why do You release a software that´s obviously very buggy?

Best
Simon


(Pascal Golay) #4

Hi Simon - if you have an example step file that shows this, please post it here or send to tech@mcneel.com.

thanks,

-Pascal


(Simon Heufers) #5

Hello Pascal,

import option works correctly for .step, .sldprt, .sldasm,
however in 5 it was possible to open .step directly without any problems.
(solidworks 2017)

Thanks
Simon


(Pascal Golay) #6

Hi Simon - so the problem you see is Open as opposed to Import, do I understand that correctly? It may be fixed in the latest, I’d like to try one of the files that has given you trouble…

thanks,

-Pascal


(Brian Gillespie) #7

RH-44286 is fixed in the latest Service Release Candidate


#8

@brian Just made a test file and holes seem OK with the latest SR. I also wanted to test how tori import as V5 has problems with Fusion’s step files. The fillets made from trimed tori don’t show any iso curves, is that expected? Shrink makes the display how I’d expect.
image

temp.step (49 KB)

Thanks Mark


(Pascal Golay) #9

Hi Mark - I think that is expected - if you untrim one of theses you’d get the full torus.
@Hughes_Tooling - is that torus floating in the middle expected or is it meant to be trimmed by the cylinders?
Never mind, I was in V5… Sigh. Is it Friday yet?
-Pascal


#10

The Fusion export was updated a couple of months back and broke Rhino V5 import of tori. I think in the past the export shrank the tori and that’s why it looked different in V6. After untriming as you suggested I understand what’s happening now.

Thanks Mark


#11

@pascal Just testing some more with tori and the attached file fails to import correctly.


Should look like this.

Thanks Mark
temp.step (7.1 KB)


(Pascal Golay) #12

Hi Mark - got that, thanks.
https://mcneel.myjetbrains.com/youtrack/issue/RH-44467
-Pascal