When I’m trying to place BackgroundBitmap Rhino shows just white space. What’s wrong?

Is your image CMYK or RGB? Rhino currently only supports RGB if I recall correctly.


It’s BMP file. Honestly, I don’t know difference between bmp, rgb and cmyk.
I’m doing Exercise 23 - “Handset” from Level 2 Manual.

BMP is a file format. RGB (red,green,blue) is a method of specifying the colors in the image - usually used in images thet will be seen on computer screens, as they also work in RGB. CMYK is Cyan, Magenta, Yellow, Black - a different method of specifying the colors in the image. CMYK is usually used in the print trade as the inks are those colors for four color printing. The two systems are actually the inverse of each other, one is emissive/additive (light), the other is based on subtraction/absorption (ink on paper).

You can get info on and convert images between the systems in something like Photoshop or Gimp.

I am assuming the problem comes from that, but I’m not certain, if you can post the image, someone can check.


I’ve tried to post image but :slight_smile: “Sorry, the file you are trying to upload is not authorized (authorized extension: .dwg, .dxf, .zip, .7z, .rar, .igs, .stp, .step, .rhp, .gh, .gha, .ghx, .py, .rvb, .rui, .txt, .pdf, .png, .jpg, .jpeg, .gif, .rmtl, .renv, .3dm, .rtex, .ini, .xml, .mp4, stl, .mov, .macrhi).”

I’ve changed it to jpg

You can zip the .bmp and post the zip, that should work.

bitmap.rar (60.1 KB)

OK, they’re all RGB and they’re not too big, so that shouldn’t be a problem. I tried here and they all work fine as background bitmaps… So I don’t know what might be going wrong on your end…

Might be a graphics card problem - what card do you have? (Options>View>OpenGL) Latest drivers?


Yeah, you are not using accelerated hardware mode, even though it’s checked at the top. “Microsoft GDI Generic” is the default backup system that is used when nothing else is working. Can you determine the make/model of your video card and its drivers? Normally a right click on the desktop should bring up a menu with an item that’s some sort of video card controller (Nvidia or AMD).

Also, just as an experiment, if you uncheck the first “use accelerated hardware modes” at the top, do you see your background bitmap?

I unchecked “use accelerated hardware modes” and bitmap worked.

OK, it’s a known issue that Radeons work pretty crappy with Rhino… I have no experience with them, anyone else have any driver advice/fixes for Aram?


Since the Rhino OpenGL page does not show the Radeon card is an indication the computer is not setup correctly. Fix that first.

Download and install updated drivers for your Radeon card.
Then in Options > View > OpenGL, set the antialiasing to None and check the option for using accelerated hardware modes.
With some luck, it will work. It won’t work well since the Radeon drivers from AMD are so messed up.

Hi Aram,
You might be running a pirated version of Rhino. They are known to be buggy at least because you cannot update to the latest service releases.