Background bitmap not working

In the latest V7 wip (7.0.20217.3575, 8/4/2020)
Background bitmap is not working in this older file I opened in V7 but works in V6. The images appear as white rectangles.
The refresh option does nothing non of the other options seem to work.
Also why no option to find the file or give the name of the image file in use?
This file is working perfectly in v6 I also tried all viewport modes and nothing seemed to matter.


Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Hybrid graphics system.
Primary display: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 11-18-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 960M (NVidia) Memory: 4GB, Driver date: 4-3-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 445.87

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-3-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”!

Try updating your stale Intel driver:

There is an update for your Nvidia driver too, but it’s not that old.
I’d update the Intel driver and check.

Any luck?

No luck any other brilliant ideas.

Does this file display on your system?
It has a BackgroundBitmap attached to the Top viewport, and the same image used in the Picture command as a texture on a surface.
BB and Picture.3dm (630.3 KB)

Hi John
Yes this file you posted displays. In the first pic you can see my file works in V6 which is also installed on the same computer? So why not in V7? Updating drivers did nothing.

I guess it has to do with this being an old file and V7 just being filled with changes. I have to find a way to get the paths to the background bitmaps or maybe someone has a script or a command to convert Background bitmaps to picture frames with the same scaling and placement.
I don’t use background bitmap anymore so you can imagine how old this file is but I need to redo and add to this file now. Thanks for your help and for posting that file to check. Maybe it’s the jpg type I’m attaching one of the files for you try as a Background bitmap.

My guess is you have a working display mode setting that is interfering.
Post YOUR file please.

Here’s the file
L30-003 012.3dm (7.1 MB)

No image file came through with the 3dm.
Can you please post one of your images too?

You can try the above pic I posted and here is the file resaved with the save images option checked.
L30-003 012_A.3dm (7.1 MB)

Hello - your image shows here in V6 and V7…


Yes that image displays for me too both in V7 and V6 when I place it as a new background bitmap but if I only open the file I posted the images display in V6 but not V7 and I’m finding more weirdness.

This is in V6.
If I turn off a BB it disappears from the display. If I try the BB command again in that same viewport where the image was turned off Rhino opens the file browser as if no file was ever displayed in the viewport. If I delete a BB undo does nothing but maybe BBs don’t make it into undo stack? if I use BB move or scale commands the BB disappears from the view.

to be fair, BB was obsoleted by the picture frame and subsequently by the picture command.

if you are opening old files, I’d update the images using picture. You’ll be updated and have no problems going forward.

1 Like

Also make sure Rhino 7 uses the geforce card and not the intel card.
If the image is big it can be ignored by the intelcard.
You fix this by setting up a profile in the nvidiadriver for rhino and choose which card to use there.

1 Like

or you can disable the intel card which is the nuclear option for hybrid systems that won’t behave.

this makes rhino happy, but can be brutal on your battery life if you run a laptop unplugged.

I never run my laptop unplugged when modeling so I just kill the intel and be done with it.

you may choose differently-

@John_Brock @pascal @Holo
Did any of you try to open the file I posted?
All my drivers are fine and my computer is working well. I do use picture frames but this is an older file and I reported what was happening on my side and have yet to hear from McNeel regrading this.

One last request is there a script that can bake these BBs to picture frames with the correct scaling and placement?

neither file opens with a background bitmap here.

as that command is now obsolete, you may be stuck with re placing the images with the picture command.

If neither file opens there must also be a bug with the save with textures command. That should also be looked into. I haven’t been in Rhino for a while so I had to get used to it again.

I now realize why I did not change over to picture frames in this file. The reason is that BBs don’t interfere with each other; duh if I use picture frames they are visible in all views. BBs have the advantage of only showing in the assigned/placed views, this is huge .

McNeel please either add a “show in one view only” to picture frames or don’t get rid of the Background bitmap command. I can’t believe you want to do away with this command and replace it with something that lacks this one needed quality. The picture command could use this option big time or just leave the Background command in future Rhinos and not make it obsolete.

Secondly there is a bug I think many in the BB command which have not been addressed, just do a Background bitmap search and you’ll see the exact problem I am reporting and now I have run into more.

BBs turning into white rectangle is one.
Scale or refresh nukes the bb from the file is another.
Save with textures doesn’t save the bb images with the file is yet another since the files I uploaded I did have the save textures option checked why is that not looked into why is that not working?

One cannot replace BBs with picture frames and have the same functionality.


put the pictures on a layer and use the layer vis to turn them on or off.

Hi @theoutside
That doesn’t work at all. No matter if you have one picture or a million it will always show up in all views when you turn the layer on. Background bitmaps don’t do this. You can have all plan views set up with BBs and your perspective view will be clean with no images. This way you can easily check model alignments and modeling without having to turn anything on or off or go searching through layers.

Not one developer has checked into why this is happening in this particular file. I have rebuilt the BBs in this file and all is working well but the fact remains that the problems I encountered did occur. The responses from McNeel in my opinion were canned responses and did little to rectify the bugs. Also and worse is McNeel wants to make Background bitmaps obsolete when it has obvious benefits over picture planes.

I guess the best I can offer is background bitmap is an obsolete command, it will not be updated nor will any changes be made to it. It’s still in the software at all for the sole purpose of supporting legacy files.

I’m sorry if this response feels “canned” (we don’t do that btw) but there is really not much else we can do other than direct you to the new method for working with images which is picture.

That said…adding a feature to picture where it is view specific? that is a possibility and something I could write up as an enhancement to picture.