Autosave not working, even from command line

My Autosave is set to run every 20 minutes, but the allocated folder is empty. Even if I run autosave from the command line nothing pops up, however the files are in the recycle bin-I’m not shutting down, I know these files get shunted to the recycle bin if you shut down rhino.

Hi Martin -
Please run the Rhino SystemInfo command and copy-paste the result here.
What does the command line report when you run the Autosave command?

It says, “Autosave succeeded”
Rhino 7 SR18 2022-5-4 (Rhino 7, 7.18.22124.03001, Git hash:master @ b2a1120bcb32e1f6da66a421cd7162a18a9f0cd9)
License type: Commercial, build 2022-05-04
License details: Cloud Zoo

Windows 10.0.22000 SR0.0 or greater (Physical RAM: 28Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: AMD Radeon™ Graphics (AMD) Memory: 4GB, Driver date: 9-27-2021 (M-D-Y).
> Integrated accelerated graphics device with 2 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 12-15-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 497.29
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-15-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\export_ACAD.rhp “AutoCAD file export : export_ACAD”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\MeshCommands.rhp “MeshCommands” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\MeshTools.rhp “MeshTools”
C:\Program Files\Rhino 7\Plug-ins\import_STL.rhp “STL Import”
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\QuadRemesh\QuadRemesh.rhp “QuadRemesh” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\export_PDF.rhp “PDF Export” 7.18.22124.3001

Hi Martin -

It’s the line above that that I’m interested in.
Which directory is that file written to?

Autosaving file as C:\Users\user\AppData\Local\McNeel\Rhinoceros\7.0\AutoSave\wip7 (132390) RhinoAutosave.3dm

Hi Martin -
And your username on that machine is “user”?
I’m trying to find out if you are looking inside the correct folder.
Can you post screen shots of the Rhino file options and the folder in Windows Explorer?

Ha! Yes it is, it’s a new laptop and I haven’t got round to it yet…I’m accessing the autosave location through the options tab in rhino-so I know that’s correct. In addition the autosave file goes to the recycle bin. I.e. If i run the autosave command manually, the file that’s created appears in the recycle bin, even though I don’t shut down Rhino.
Sorry, i’m not in front of the laptop til tomorrow now, I’ll forward you anything you mighy need then. Thanks for your help so far.

What happens when you save (not autosave) a file to that folder, can you see that in Windows Explorer?

yes…and strangely that seems to be working now-autosave just backed up and it’s in the proper place…I’m not going to jinx it, but it looks like it’s decided to work. fingers crossed it continues and thanks for your help!

1 Like